3ds Max hang on submission of heavy bitmap scene

I have a scene which includes 260,000 bitmaps, as 41 separate ifl files, each of 6500 frames.
Just fyi it’s a song sung by a choir, so these are grids of multiple people for each grid.

The sequences I was rendering were actually quite short…max 200 frames…but the problem I was having rendering them was with ram use, so e.g. a 200 frame sequence I could only render approx. 25 frames before having to restart Max - a huge time-waster.

I discovered that by using Backburner I could simply stop it when I reached peak ram, then start it again to continue the sequence - all taking just seconds each time.

Someone suggested I use Deadline instead, as it has the option to restart the renderer after each frame, so it would in theory handle the job in one go.

So, although I actually completed the job using Backburner I still want to see how Deadline would handle this. And it does not, at all. I am therefore very confused and wondered if anyone can help troubleshoot this.

With Backburner, all it does is open up a copy of the file and render it. With Deadline, when I hit submit it appears to try to find and reference each of those 260k bitmaps before doing anything. And it would arguably take days to do so, if it completed at all.
The only way to get out of the process is to kill Max, as canceling the job still hangs the whole thing indefinitely.
I tested this behaviour by culling the scene to about 400 bitmaps and it runs fine, so it is certainly that part of the process that is at fault.

Is this simply some limitation, or use-case that was not expected of Deadline, or is there in fact a solution?

Nobody has a confirmation of this inability or otherwise?
Or is this the entirely wrong place to post this kind of issue?

There is an option in the submitter - tab Assets, you will see “Copy ALL External file references to repository.” Just change this to whatever is suitable for you. By default the max submitter sends included files with the job.
The accounting of assets will probably still take a long time, even if you do not upload them.
Haven’t used the 3ds max submitter in a while though, so not sure how it would behave.

Hmm, that isn’t really an option, as the files total over 150gb.

What is odd is that Backburner doesn’t need to do this - it simply opens the scene and renders it.

I should mention that I am not farming this but using a single machine, so all files are local.

Yeah my point was to turn that option off - it is probably trying to copy all assets at the moment.

Ah yes, thanks, I did turn that off but it had no effect.

Privacy | Site terms | Cookie preferences