AErender OpenGL issue

Hello community,

we used Deadline as rendermanager with After Effects CC 2018 on a Windows7 - based renderfarm for years without problems.

Recently we upgraded the whole renderfarm to Windows10, and now cannot render with after effects anymore.

each task immediately stops with the error messages

  • GL Error: Need WGL_ARB_create_context
  • GL Error: OpenGL load failed

some further information:

rendernodes only have onboard graphic cards -> no hardware acceleration
rendering is set to: Mercury Software only
no plugins used
overall setup is exactly the same as before (only running on win10 instead of win7)
it happens in both cases when deadline slave is running as app and when running as service

when we manually execute aerender via commandline, it gives the same 2 error messages, but starts to render fine a couple of seconds later.

i already tried to get help from adobe but… no answer :frowning:

is there any way to solve this?
since it actually does render after printing out the given messages when started locally, i’m wondering if there is any way to manipulate deadline’s error handling?
is the reason for deadline marking the task as failed the error message itself or by an exceeded timeout before actual render starts?

thx in advance

Hello!

From the sound of things it does look like it’s After Effects throwing errors that Deadline doesn’t recognize. So then it creates an error, and fails the task.

Would you be able to share a full error log with us? If you don’t want to go through the work of sanitizing it to be safe to post on the internet you could create a ticket with us at support.thinkboxsoftware.com.

I have a same problem

In ours machine we no have GPU
os window 8
we use only CPU to rendering

I have set Mercury Software Only
I have Ignore (self.AddStdoutHandlerCallback(".GL Error:.").HandleCallback += self.HandleNonFatalError ) in affter effect plugin it but still not working

any more ideal suggest to solve this ?

When you say it’s not working, how is it failing? Your addition looks correct, assuming you’ve added it in the InitializeProcess function.

If you could get me a job report where you’re seeing this that would be great!

Privacy | Site terms | Cookie preferences