AWS Portal Link Cannot Establish Communication With AWS

Hi,

I got this error message after creating the “Deadline Infrastructure” and clicking on “Start Spot Fleet”.

AWS Portal Link cannot establish communication with AWS. Check that AWS Portal Link is running.

Possible causes of this error are:

  1. Port 22 is blocked outbound from the AWS Portal machine to the Gateway.
  2. The wrong public ip is set in the security group of the Gateway for port 22 (SSH).

image

I did what was explained here, but still got the issue:
https://docs.thinkboxsoftware.com/products/deadline/10.1/1_User%20Manual/manual/aws-portal-troubleshooting/workers-not-connecting.html

Also from the Cloudwatch Log Dialog, there is this message in repeat:

Could not connect to the RCS. Connection response: ‘502 Bad Gateway

502 Bad Gateway


nginx/1.12.2’

When the infrastructure is no created AWS Portal Link: Online
Once the infrastructure is created AWS Portal Link: Not Connected

From the AWS Portal Link Log:

[SSHTunnelManager] Access denied connecting to remote host 15.237.55.80.

Please, can anyone point to what to do in order to connect?

I could get it to work thanks to the AWS Portal Link Troubleshooting guide:
https://docs.thinkboxsoftware.com/products/deadline/10.1/1_User%20Manual/manual/aws-portal-troubleshooting/aws-portal-link-error-messages.html

It was the “Permission denied” error.

An error has occurred that perfectly matches this following.

But we ran the same thing, but the problem was not solved.

In addition, all the methods in the link have not been solved.
[AWS Portal Workers Don’t Connect to Repository — Deadline 10.1.15.2 documentation]

Please, can anyone point to what to do in order to connect?

1 Like

Try following the steps to connect to a worker here.

Since the AWS Portal components connect over SSH, this is way to see if you have any issues establishing an SSH connection to the Gateway machine and any Workers that are connected to it.

If that succeeds, make sure that you’re providing AWSPortal the correct certificate when you create an infrastructure. You want to use the same certificate you use to connect to the Remote Connection Server. Called DeadlineDeadline10RemoteClient.pfx by default.

If you have any trouble, share it here!

Privacy | Site terms | Cookie preferences