Bootstrapping nuke

Hi,

I’m trying to get Shotgun Write nodes rendering through Deadline. I’m following the method here pretty closely:

But I’m getting this error:

Error: [ 9:16.18] ERROR: Shotgun Error: [ERROR tk_nuke] The Shotgun Pipeline Toolkit is disabled: The path 'C:\Users\primaryadmin\AppData\Local\Thinkbox\Deadline10\slave\BEIGE\jobsData\5fdc733337746368107d29a8\thread0_tempuVXQl0\mdbrd_010_comp_scene_v001.nk' does not belong to any known Toolkit project!

I’m assuming that this bit:
Error: [ 9:16.18] ERROR: Shotgun Error: [ERROR tk_nuke] The Shotgun Pipeline Toolkit is disabled: The path
means that the SG script user and Key are not being picked up by the render slave.

I’m assuming the path, which seems to be a path to a temp version of the script on the render slave, is a result of the SG toolkit not being launched.

If anyone would be able to clarify all this and point to a solution I’d be grateful

thanks in advance

Steve

Actually we have solved this one! Or at least I think…

You have to disable automatic context switching in your toolkit configuration.
This prevents Nuke from trying to make a context out of the temporary scene in AppData.
You should bootstrap the engine with the proper context before that.

Thanks Mois, I think that fixed it. It’s now failing due to another issue, but I think this is a question for the peeps at SG.
Thanks again
Steve
:slight_smile:

1 Like

I wish there was a better way, honestly. The other option now is to convert write nodes on submission, which is worse in several ways.
Ideally you will have Shotgun write nodes, which do nothing when sgtk cannot be imported, and they already keep their path. I guess it can be achieved with some tweaking of tk-nuke-writenode.

Privacy | Site terms | Cookie preferences