C4D Take token not expanded


When using this as outputpath in c4d and submitting with the intergrated submitter:
I get this warning when i right click -> explore output in Monitor when the job is finished:


It doesnt seem that the $take token is expanded in the “OutputDirectory0” var in the job info.
Is this an easy fix?

DL / R19 / Win 10



We currently have an issue open here for a problem when tile rendering where the tile assembly config file does not have the variable expanded. In your case it looks like it’s slicing off the end after “$take”. Is “$prj” being replaced properly?


Prj expands just fine


I think the length is correct, ending with $take in my case. It just doesnt expand


I don’t like to blindly recommend upgrades, but I wasn’t able to find much from my searching of the developer issues. I would expect this to have affected many more people at this point if we had not fixed it, and I do remember this was an issue in the past.

Would you be able to upgrade to 10.0.20 to see if it helps? Again, tile rendering is still impacted at the moment, but standard output should be fine.

Downloads here, docs here.


Ill try to update on monday :slight_smile:



Hey Bonsak,

I just wanted to check in with you to see if updating fixed this. If it has not been fixed would you be able to provide a scene that you can reproduce this it would be very beneficial since I have not been able to reproduce it yet.



Havnt had time to upgrade yet. Ill try next week.



Hey Bonsak,

Just wanted to check in on this again to see if you have had time to upgrade yet.


Finally got time to upgrade. This seems to have been solved. Thanks!



Great to hear. I am going to close our internal issue then. If you run into any more issues with this please let us know.



It seems that this error persists if you only submit the main take but you still have $take or another token in the path.
It seems the tokens in the filename is the ones not expanded. The path it self is resolved.
DL, R20.0.030



So, the steps to reproduce are:

  1. Set the output path to have $take in the output path.
  2. Submit a project and only use the main take.

We did test this at the beginning of October and weren’t able to reproduce this one… Would you be willing to make a really simple C4D scene and pass it here?


Sure. Will post tomorrow. This only happens when tokens are in the filename and no extension is spesified. Tokens in the path are resolved.



@eamsler I sent you a DM with a link to a case file .



Any news on this?



I’d also like to ask if this issue is something that is being worked on - we regularly need to check output files remotely and not having the ability to see straight away whats going on because of this missing path / token issue is a definite problem for us C4D users.

Any update would be much appreciated!


Hi @eamsler. Has this been fixed yet? We are using and the symptoms are the same as i described in december, except i dont think it has anything to do with the file exstension being present or not:

This only happens when tokens are in the filename and no extension is spesified. Tokens in the path are resolved.

  • Make a project and make a take that is a child of the main take, with an output path like this in rendersetings:
    ../../Elements/3D-render/$prj-$take/$prj-$take (dont think the …/…/ matters)

  • Submit All takes-. Include main take using the Batch plugin.

  • Explore or View output on the Main takes tasks results in this error in Monitor:
    ../../Elements/3D-render/Piano-$take/Piano-$take0188.png" does not exist.

  • Explore or View output on the child take tasks works:

As you can see the $take token is not resolved but the $prj token is. This only happens for the Main take.
Submitting at take other than Main does infact resolve the $take token.
So it works if take is not Main.