AWS Thinkbox Discussion Forums

Can I disable Worker Local Data Storage?

Hello everyone!

I’m upgrading DL8 to DL10. I’ve just found out about the Worker Local Data Storage feature, which results in errors for my codes that rely on current folder structure and file locations, since the file runs on the worker machine instead of it’s original, network drive location.

I didn’t see this happening in our DL8 though. I can find the local folders in ProgramData, but they doesn’t contain any code copied from the network drive.

Can I somehow turn this feature off to run the auxiliary and other files where they are originally, without copying them to the workers’ machines, or this is a DL10 feature I have to live with from now on?

does that help? can you write the stuff elsewhere?

Thanks for the quick reply!

If you refer to setting a different path for the SlaveDataRoot in deadline.ini, it won’t solve my problem.
I want my code to stay where they are and run there, and not being copied to the worker machines and run there.

If the machines running Deadline are diskless, it may be necessary to redirect other paths as well. The full set of environment variables which can be modified are described in the Environment Variables section below. You can use these to configure Deadline to avoid writing to local directories, protected directories, or to paths which aren’t mapped to persistent storage.

This was the bit I thought may help , if there isn’t a way to not copy the data, at least you can re-reoute it

This link makes it sounds like a ‘must’

Privacy | Site terms | Cookie preferences