Deadline pulse is assuming the wrong NIC ethernet for IP

Since updating to 10.1 I’ve experienced a problems with Deadline pulse. It is incorrectly assuming connections through the wrong ethernet interface, eth0 in ubuntu. It should be using eth1. so when it starts, it reports to the repository that it is available at ip 10.0.2.5 (eth0) when it should be 192.168.92.22 (eth1)

Is there a way to force it to use a different nic or IP?

You can set the IP as an override

There is an option in the Reposoitry
As mentioned above, there are the global Pulse settings in the Repository Options, which are applied to every running instance of Pulse.

And you can override each pulse
https://docs.thinkboxsoftware.com/products/deadline/10.0/1_User%20Manual/manual/pulse-config.html#general

PS. nice work on OpenFireHawk if that’s you!

1 Like

Thanks Anthony!

Can this be configured via a Linux shell or during the installation via a comandline argument?

That’s a setting set in the database, so there’s not any supported way to edit that (the database schema is subject to change at any time).

This might not be a good idea, but could you re-name the interface you want to use to eth0, and rename the other? Just thinking about the halves of this equation that can be hit without a GUI. Since it seems that Deadline is grabbing eth0 unless there’s an override we might be able to exploit that.