GlobalJobPreload not executing

Hi,

I’m migrating the repository / database from a Windows VM to a Linux VM. The setup is working for the basic cases, but the integration with our pipeline depends on the GlobaJobPreload.py to alter the job command line. Jobs executing using the Linux VM as the repository source don’t execute the GlobalJobPreload. Any pointers on getting that to be active would be appreciated.

I’ve tried putting the file in the repo/custom/plugins and repo/plugins folder. Neither works.

This is using 10.1.6.4 on Ubuntu 18.04, for what it’s worth.

Thanks in advance,

For a little more detail on this, on the new server, we get output like this from a command line job

2020-06-03 14:47:16: 0: Executing plugin command of type ‘Render Task’
2020-06-03 14:47:16: 0: INFO: Executable: ls
2020-06-03 14:47:16: 0: INFO: Arguments: -l /Volumes
2020-06-03 14:47:16: 0: INFO: Execute in Shell: False
2020-06-03 14:47:16: 0: INFO: Invoking: Run Process
2020-06-03 14:47:16: 0: INFO: File “ls” is not rooted, checking current directory

On the older server, the jobs produced something more like
2020-06-04 21:54:09: 0: Executing plugin command of type ‘Render Task’
2020-06-04 21:54:09: 0: INFO: Executable: /some/path
2020-06-04 21:54:09: 0: INFO: Arguments: some args
2020-06-04 21:54:09: 0: INFO: Execute in Shell: False
2020-06-04 21:54:09: 0: INFO: Invoking: Run Process
2020-06-04 21:54:09: 0: PYTHON: -
2020-06-04 21:54:09: 0: PYTHON: Entering GlobalJobPreload AlterCommandLine
2020-06-04 21:54:09: 0: PYTHON: -

So the GlobalJobPreload is triggered right after the ‘Invoking: Run Process’ line on the old server, but not on the new.

So… the typo that tripped us up is in the subject of this post.

On linux, the search for “GlobalJobPreLoad.py” is case sensitive. If you don’t capitalize the L, like we didn’t in the subject for this post and on our server, the file won’t be found. Making sure the capitalization in the file name matches exactly solved the problem.

On Windows and Mac, the search isn’t case sensitive, apparently.

Thank you Thinkbox Support for sorting that out for us!

1 Like
Privacy | Site terms | Cookie preferences