Houdini Simulations


#1

Hi,

this might not really be a Deadline question, but I’m curious on how to submit simulation jobs to Deadline. Or if it’s even possible.
I’m running Houdini Indie - which does not include HQserver or HQclient, but does have the Houdini Engine.

Seems I can submit mantra renders just fine, but getting errors on wedges or other ways sending off the simulation output driver.


#2

I’ve had success with Houdini Indie and submitting both wedged simulations and non-wedged. In my case FLIP fluid sims. I used the integrated Deadline submitter for Houdini and selected the wedge node or the (in my case) AutoDOP/export/render node.

Is the error in Houdini or Deadline?


#3

Can you post the errors you’ve been having? Sims should work as long as you’re not distributing the sim itself.


#4

Good to hear it’s supposed to be working. I’m coming from a 3dsMax pipeline, so Houdini is still new to me.

So my Wedge SOP uses the output driver from my File Cache node, connected to my DOP simulation. It’s an RBD sim, and I’m writing out the point caches. This works fine locally, but submitting the job (also along with the Houdini file) gives me this error:

What would be the best way to submit the simulation to Deadline?


#5

Hmm. Best guess is that one of the nodes is locked somehow (I wasn’t even aware that’s possible). I’m guessing we’re trying to set the start and end frames on one or more of your ROPs and Houdini isn’t allowing that.

I’ve seen the same sort of thing with locked properties in Maya.


#6

Thanks, Edwin. I can send over the scene if that helps for debugging. Let me know.
As far as I know, there isn’t anything locked that I’ve seen in the scene either.


#7

Sure! I could put some debug code in so it’d hopefully tell me which node we couldn’t edit. I’d have to check what function lives at line 35,256 so knowing what version of Houdini you’re using would be good too.


#8

Sorry for my late reply on this one.
Your reply actually brought me to the solution when I went back to the file. Since I grabbed the ouput driver (needed in the Wedge) from inside a File Cache SOP, I had to right click the File Cache and enable “Allow editing” before submitting. Works now, but probably something you can add a fix for in the next DL release.

The submitter is not respecting “submit wedges as separate jobs” though, but I saw there’s already another thread about that issue.
Thanks!


#9

That sounds like a pretty good sanity check. I’ll add it as an enhancement request.