Launcher will not run after upgrade

Hi, I upgraded to deadline 10.1.16 and now my launcher does not launch. I ran monitor from the command line with -console switch and I get an error that there is no module named ‘cPickle’.

I am not sure how to fix that but wanted to know if there is a solution for this. Thank you.

-Christian

“There is no cPickle in Python 3. Just import pickle . pickle will automatically use the C accelerator.”

Thanks but how do I get the deadline launcher to decide what modules it needs to load? In other words I don’t know how to change the deadline launcher loading procedure or if that’s even possible.

Below is the full error message from running launcher with the console switch.

daemon was not added to the CommandLineParser.
Auto Configuration: Picking configuration based on: phoenix / 10.12.16.61
Auto Configuration: No auto configuration could be detected, using local configuration
Attempting to decompress pythonsync from \server-2\DeadlineRepository10\pythonsync\pythonsync.zip to c:\Program Files\Thinkbox\Deadline10\bin\pythonsync
pythonsync decompression successful
Attempting to decompress pythonsync3 from \server-2\DeadlineRepository10\pythonsync3\pythonsync3.zip to c:\Program Files\Thinkbox\Deadline10\bin\pythonsync3
pythonsync3 decompression successful
Launcher Thread - Launcher thread initializing…
Launcher Thread - opening remote TCP listening port 17000
Launcher Thread - creating local listening TCP socket on an available port…
Launcher Thread - local TCP port bound to: [::1]:50957
Launcher Thread - updating local listening port in launcher file: 50957
Launcher Thread - Launcher thread listening on port 17000
upgraded was not added to the CommandLineParser.
upgradefailed was not added to the CommandLineParser.
service was not added to the CommandLineParser.
daemon was not added to the CommandLineParser.
Comparing Deployment Versions of Repository and Client to validate if auto upgrade is supported.
Repository and Client Deployment Versions are supported for auto upgrade.
Local version file: c:\Program Files\Thinkbox\Deadline10\bin\Version
Network version file: \server-2\DeadlineRepository10\bin\Windows\64bit\Version
Comparing version files…
Version files match
IsLocalBinFolderWritable: Touched file c:\Program Files\Thinkbox\Deadline10\bin\TestFile_286c20ec-e1eb-4945-bbf2-899d7337ca00.
Exception on Startup: An Unexpected Error Occurred: ModuleNotFoundError : No module named ‘cPickle’

Deadline Launcher will now exit

It is not entirely clear where the error was thrown - no stacktrace. Some module in Deadline that has not been properly upgraded to Python 3, it seems.

I bumping this thread in the hopes that someone at Thinkbox can give a hand here. Still a problem on this one machine and I have tried uninstalling and re-installing the client application as well as deleting stored settings but nothings seems to make this go away.

Please help. Thanks.

Privacy | Site terms | Cookie preferences