Maya submitter walways sends all render layers

Hi,

whatever I do, the maya submitter does not respect the renderable flag in the render setup.

It always sends all the layers, including the default masterlayer. Is anybody having the same issue? Any fix?

Many thanks

Hi Eric_Mc_Guire

You would need to disable/enable render layers in the scene and then submit the job. You can disable the render layers from “Render Setting” in Maya. These can’t be set in the submitter.

Hi Zainali,

I appreciate the support a lot. However I don’t understand where I could toggle the renders to be sent in the render settings.

Normally I enable and disable them in the render setup window if that’s what you meant, which is what I was saying as well.

So as mentioned, the maya submitter at the moment does not respect my layer selection as shown, it just sends all the layers. I should also mention that I am submitting Maya + redshift jobs as shown below as well.

Thanks again for your help, it’s very annoying to delete all the unwanted render layers at each submission…!!


Is there any follow-up on this? It’s even worse when we don’t write a multichannel file, the aov’s go in the persp folder and the beauty goes in the camera folder. It’s not doing that with the standard maya batch rendering. Can you help please?

It’s a bug in the submitter and it should be resolved. Thank you!

Privacy | Site terms | Cookie preferences