Nuke submission TypeError: expecting a string or number, unicode found


Hi there,
We’ve just updated our deadline repo. (version info below)

I’ve updated the nuke submitter script to the one included in the repo but I’m getting the following error when submitting to deadline.

Traceback (most recent call last):
File “z:/studio/nuke/release/v1.0.3/Repository/_AutoInstaller/deadline\”, line 52, in main
SubmitNukeToDeadline.SubmitToDeadline( )
File “//path_to/studio/dr10/custom/submission/Nuke/Main\”, line 2098, in SubmitToDeadline
dialog.pool.setValue( DeadlineGlobals.initPool )
TypeError: expecting a string or number, unicode found

I know I can fix this by encoding the strings prior to getting the values, but as that’s a pretty major ‘fix’ to implement, I’m wondering why this is happening at all.
I’m submitting from a clean nukescript so there’s no legacy deadline data in nuke.root()… but perhaps I’ve missed something.

Any idea what I’ve done in my config to break Deadline?


Version Info

Nuke 11.1v6
Windows 10
Deadline Launcher 10.0

An application that provides a means of remote communication between the Deadline Monitor and the Deadline Slave / Pulse applications.

Deadline Client Version: Release (b262943da)
FranticX Client Version: Release (9beef8dc3)

License Mode: Standard
License Server: @licserver

Repository Version: (b262943da)
Integration Version: (b262943da)
3PL Settings Version: 16/04/2019


All fixed. My sticky settings must have been corrupted.


Actually, this is still a problem.
If I delete my sticksettings, I can submit.
If I restart nuke, on submission I’m getting the unicode errors again.

It appears configParser is returning unicode values by default and nuke knobs can’t be set to unicode values.
Is there any way to override this behaviour without having to edit every value in the file?

What I don’t understand is that this is the behaviour as supplied by deadline… and I assume it should work, but for some reason its not working for me. What might it be about my environment that might be causing this issue?

Thanks again.