Nuke support for GPU Rendering

I can’t seem to be able to get GPU rendering to work with Nuke on Windows. I have a few render machines with dual GPUs. I’ve created a worker for each GPU, and set GPU Affinity so that each worker will use one of the two GPUs. When submitting a nuke job I see a “GPU Rendering” checkbox. If I tick the box and then assign it to my GPU worker groups… I still see tasks only rendering using CPU.

GPU usage stays very low, and CPU usage matches our normal Nuke render usage.

I’ll also add, that leaving GPU affinity to default on workers (so that it uses all available) also fails.
Is this supported?

Hello!

Double checking - you’re talking about the ‘Use the GPU for Rendering’ checkbox?

And are you running at least Nuke version 7? And lastly can you tell me which version of Deadline you’re running?

And would it be possible to see (either here or in a support ticket) a render log where this is happening?

I notice the same behavior on linux. Nuke12.1v2, DL 10.9.1.2

One GPU display high usage, the other barely anything.

If you’ve got one handy could you share a render log where you’re seeing this behavior?

If you’re not comfortable sharing a log with the internet (due to file names and NDAs) you can submit a ticket to awsthinkbox.zendesk.com and just mention this forum post.

Privacy | Site terms | Cookie preferences