Shotgun Upload

Hello all,

After updating to Deadline 8, Draft stopped uploading the encoded version to Shotgun. I found that the version ID field is missing:

However, I can see the version ID in job info parameters. I traced down, Shotgun scripts and Nuke submitter but couldn’t find why the version ID is missing even though it’s created.

Any idea?

Hi there,

I’m sorry you are having issues… I would like to ask you two things.

First, can you tell me the order of execution of the Shotgun and the DraftEventPlugin plugins? Which one is executed first? (From the monitor, in your Nuke job report, you should be able to see the log for both and the corresponding time.)

Second, can you try to requeue the Nuke job only? Does it make any difference?




DraftEventPlugin is running before Shotgun Plugin. And I’ve submitted Nuke job without Draft option and it uploaded the Shot to Shotgun. However, it was doing this with Draft option was on as well.

Thanks a lot!


I’m glad you were able to upload to Shotgun.

In order to make things simpler for next time, I would like you to try the following. From the Deadline monitor, while in super user mode, can you go to Tools->Configure Events->Shotgun and set Create Version on Submission to True? Hopefully, this will solve your issue and your shot will be uploaded to Shotgun on the first try. (Note that you might need to restart the monitor and the slave to ensure that option is effectively set to True.)

Please, let us know how this goes!




That option is already on and Nuke job uploading was already working.

Draft uploading to Shotgun is what’s not working. The version ID is missing for that. But I don’t know why that’s the case.


Hi there,

Here’s what I think is happening. Since the DraftEventPlugin starts its execution before the Shotgun Plugin, the Shotgun Version has not been created yet so that’s why you are getting:

WARNING: Could not find an associated Shotgun Version ID. The Draft output will not be uploaded to Shotgun.

Note that your Shotgun version will effectively be created, but just a bit too late. If you requeue your Nuke job (by right clicking on it from the Monitor and selecting Requeue Job – no need to submit your Nuke job again) Draft will be able to find the Shotgun version and your shot will get uploaded to Shotgun.

On the other hand, if you set Create Version on Submission to True in Tools->Configure Events->Shotgun, I believe the Shotgun Version will be created right away and Draft will be able to find it when it needs it. I tested this locally on my machine and it appears to work fine. (Note that I had to restart the monitor and the slave after setting that option to make this work.)

I’m very sorry you are experiencing that issue. I hope we’ll be able to make this work for you quickly!



That option was already on the whole time but it’s still not working. Is there a way that I can change the execution order from the scripts or so?



There might be something else going wrong then. Can you open a ticket through our Thinkbox Support Ticket System?

We’ll be able to better help you from there.

Thank you for your patience!