Silent install


Hey there, after banging my head against a brick wall over and over i finally got around asking instead. I’m trying to set up a silent install of deadline/repository on my windows machine, have read the documentation inside out, but no matter what it always ends up with deadline/repository being installed on C:\ instead of specified path, so i figured that i must be doing something wrong or missed something. Following is the pseudo code i have been testing with. Would love some feedback what is wrong, and some non pseudo code to clarify how it “should” be done. Thank you in advance :slight_smile:

\network\share\DeadlineRepository.exe --mode unattended --prefix “E:\Deadline\Repository” --installmongodb true --mongodir “E:\Deadline\DB”


I remember having lots of troubles with silent installing anything that was made with the installer type that is used here (I can’t remember the company it comes from from my head).

I remember it being a very stupid thing like not supplying a parameter that was not optional (but was not described anywhere as being required)


Bitsrocks is the compiler is what i could understand from the documentation.

And yes, this installer type is the only one giving me so much grief compared to most other. I have tried so many combinations and googled for any sort of solution, but very little to nothing shows up except official documentation that hasn’t helped me to solve the problem so far. One funny thing is that even the docs say that the default install dir if not specefied otherwise is “C:\Program Files\Thinkbox\DeadlineDatabase8”, but when run from a silent install options or no options, it installs itself under “C:” rather then program files. scratching my head here :confused:


Well, the good news is the client installer worked alright:

C:\Users\edwin\Desktop>DeadlineClient- --prefix “D:\IDontExist” --mode unattended

Your flags worked pretty well for the Repo installer too actually until MongoDB wasn’t able to start (Changed to “D:\deadline”, installed onto a thumb drive):

I’m wondering if it’s the UNC path used or if the E drive is somehow not working when it’s run… How far along did your install process get?


It finished without complaint, but on C drive. hmm but your comment birthed an idea, maybe the actual install path needs to be an UNC path. when i think of it that is logical from a usage perspective. Gonna have to give it a go in a bit, might be whats causing it to go for default install

scratch that, was a good idea though… :slight_smile:
tried a couple of different things alas fail. made a shared by all folder, tried to install to that unc. Also as you see, tried to install from local path. Starting to run out of ideas :S

start C:\Users\Administrator\Desktop\Deadline\DeadlineRepository.exe --mode unattended --prefix “\\shared\Deadline\Repository” --installmongodb true --mongodir “\\shared\Deadline\DB”


Oh boy. Please don’t install the Database to a network location. You’re creating two points of failure there when mongodb.exe on one machine is loading its data from another. It’s your call, but it makes me unhappy.

The UNC paths may be because the installer is running as the UAC split admin account. That won’t have the same credentials registered as your non-admin account that all the apps are running as. Try opening Notepad as admin and access those UNC paths, you should see the same thing. Deadline’s a bit of a special beast because it’s not that uncommon to use file shares during installation.

More info here: … -uac-is-co


Not sure if we are talking about the same issue here. I think i need to be a bit more specific about my setup and whats been done so far.

Im currently at a workstation with 3 physical Disks, C, D, E, no mapped drives. I dont have any domain environment on this comp, logged in as default renamed administrator account with full rights, UAC turned off

I have tried command line installing
from files moved to C:\User\Desktop to the same C:\ drive
from \UNC\networkShare to C:\ and also to D:\ originally
From C:\ to UNC folder

Simply put, no matter if i try installing it locally or from share, result is the same, it always defaults to installing in C:\Deadline. Feels like im missing something here.