Tile Rendering with VRay and Maya


Hi, I am trying to get Tile Rendering to work correctly with V-Ray standalone and vrscene files exported from Maya.

Things that are not working correctly right now are:

  1. If I do not enable “Override Resolution”, the render will be black. The black frames do have the correct resolution. Enabling “Enable File Parsing” is not enough. When I enable “Override Resolution” it renders correctly.

  2. The filename Deadline extracts with “Enable File Parsing” has a “_tmp” at the end of the filename. Apparently Vray for Maya adds a _tmp to the output filename in the vrscene file. When rendering with Vray standalone, this gets stripped. But when using “Tile Rendering”, it gets used. It would be great if Deadline would strip this as well when rendering tiles.

  3. Not all Render Elements get picked up by Deadline. In my testscene, only the Sample Rate element gets picked up by the vrayscene parser. Z-depth and Multi Matte get ignored. I did not test any other elements.

  4. Even when animation is disabled in Maya, the filenames have a framenumber at the end. This framenumber is missing in the Draft assembly config file so the assembly job fails. When animation is enabled, even with just one frame, Deadline picks it up correctly.

Here are some screenshots of my settings.

Please let me know if you want the Maya file, vrscene file, Draft config or if you need any other info. If you think that any of this is a bug on Chaosgroups side, please let me know so I can bring it up with them.

Maya 2017 Update 3
VRay 3.52.03
Deadline 9.0.5

Cheers, Florian


The standalone V-Ray submitter has been fairly rough lately. I would very much appreciate the Maya scene and VRScene file so I can test and also pass along to the dev team to play with.


Hey Edwin,
here is a ZIP file with the Maya scene and the vrscene file I exported from it.
DeadlineTileRendering.zip (7.49 MB)


Any news on this?


There is! The good news is that last week we solved the blank frames and render elements issues. Those were merged in last week, so I would expect them in the next service pack of 9.0. It seems the channels we’re now looking for are the following:


I’ve followed up about the file naming issues you brought up, so we’ll have to see what the integration team thinks about those ones.


Great! Thanks.


Hi there,
I have to bring this topic up again. I have been testing this feature with the latest Deadline 10 version.

Testing with a medium complexity production scene
When parsing the vrscene file, a large window that spans the whole screen pops up. No buttons are visible on screen. Pressing enter starts the render without assembly job. Jobs throws error “Error: illegal character in path. (System.ArgumentException)”
“Submit Dependent Assembly Job” is checked.

This is what the entry in the vrscene file for the output looks like:

If I specify the output file, Deadline parses the render elements correctly and also submits all needed assembly jobs. After the render finishes, the assembly job does not start automatically even though all dependencies are fulfilled. When I start the assembly job manually, I get the following error message in the logs.

2017-09-21 09:59:00:  0: STDOUT: RuntimeError: exr_input_file Error: failed to open exr file //SERVER/FOLDER/FOLDER/FOLDER/FOLDER/FOLDER/FOLDER\_tile0_TileRendering2_0002.0001.exr

I did notice the \ just before the filename which might be causing this. In the render settings in Maya (and thus in the vrscene file), the output path is using / while Deadline (on Windows) uses .

Testing with a low complexity test scene
If I test with a low complexity test scene (one light, one plane, one extra render element), I get the following error message when parsing the vrscene file:
“The vrscene file does not contain any output file name data and no overrides were set. Please resolve these issues and submit again.”

If I set the output path manually, I get this error message:
“The vrscene file does not contain any output file resolution data and no resolution overrides were set. Please reolve these issues and submit again.”

If I manually set the resolution as well, the render is submitted correctly along with the assembly job. Once the rendering has finished however, the assembly jobs do not start automatically.

Looking at the vrscene file I can find all the needed information like this:
SettingsOutput vraySettingsOutput {

So it looks like the vrscene parsing in Deadline is somehow still broken.

Maya 2017 Update 4
VRay 3.52.04
All systems running on Windows 10

Please let me know if I can help in any way to resolve this.

Cheers, Florian


Okay! I’ve finally sat down and starting looking into this.

That giant text box is supposed to be showing a list of output file names, but it’s returning text which means get_output_data_from_vrscene_file() in VrsceneUtils.py is having trouble. This is definitely going to need test data. If you could pass the tests over here it would be quick for me to test it out, but I’ll run your previous scenes through to make sure they don’t reproduce there.


here is a test .vrscene file that produces the error.

Happy bug hunting.

TileRendering2_0003.zip (665 KB)


Got it! I had issues immediately, so I’ve passed it to the dev team as well. Thanks for the vrscene file!


Okay, the code has been merged!

I’ve included the files here in case you want to try them before they’re released in a public build. They’ll likely only work well in Deadline 10 for those who may be behind a major version or two.

The files’ll go in these locations: (please backup originals just in case)
VraySubmission.py.txt (57.5 KB)
VrsceneParser.py.txt (12.9 KB)


Awesome. I will give them a try and report back.


when I test it with the test scene I uploaded here, Deadline seems to parse the file correctly. When I click on “Yes” in the “Continue Submission” dialog,
I get the following error:

Error: More than one auxiliary file is named “tilerendering2_0003_3mask…exr_1_config_2017_10_11_21_20_24.txt”, auxiliary file names must be unique. (Deadline.Submission.DeadlineSubmissionException)

Nothing is started to the farm.

If I specify the output filename in Deadline, I get the same error message but a job is actually started on the farm but no Draft assembly job is created.

Cheers, Florian


Another thing I noticed:

When I have my animation settings in the Maya render settings set to:
Animation: Specific Frames
Frame name padding: 0

The assembly job will fail because it can’t find the individual tile images. Deadline is looking for files which have a … (double dot) before the file extension. The frame padding would normally go after the first dot but since it is set to 0.

Reason for using this setting in Maya: VRay will always save to the TMP folder in the renderings folder if not rendering an animation. If I am just rendering a still, setting frame name padding to 0 will get me a file name without a frame number.

Here is the error message.

2017-10-12 14:05:18: 0: STDOUT: Unable to read file //FILESERVER/Projects/Project/3D/maya/renderings/sh03/sh03/Project_BigSur_sh03_0005/15M\_tile0_Project_BigSur_sh03_0005_15M..exr for tile Tile0 2017-10-12 14:05:18: 0: STDOUT: exr_input_file Error: failed to open exr file //FILESERVER/Projects/Project/3D/maya/renderings/sh03/sh03/Project_BigSur_sh03_0005/15M\_tile0_Project_BigSur_sh03_0005_15M..exr



Thanks for testing. We made a change to where the config files were being written to, so I’m assuming it’s there. Asking the dev team how this was tested…