AWS Thinkbox Discussion Forums

Upgrading and migrating old deadline to latest

We are attempting to upgrade our deadline from 10.0.23 to 10.1.23 (Latest) as well as migrating it (we currently have it on a windows server and want to move it to a linux/centos 8 server).
The question we have are with now that deadline is free, do we need a new license?
And our current plan to do this is to stop all deadline services; upgrade deadline on the windows machine and then stop it and move it to the centos 8 server. Is this correct?
What happens to the current license server, etc?

1 Like

Note there were reports on this forum a few weeks ago that the installation procedure of one of the 10.1.23 versions is broken. Check if it is not the same version (I think .6).

I am also interested in whether the license server would still be needed.

It broke? ok. ill see if i can find it.

Why upgrade? Why not install a fresh repository & latest repo on the new linux server and import the old settings from the other server?

I’ve seen the upgrade break, it just hangs forever (especially on old repos with large log/report/stats folders) seems to function once the hanging upgrade windows is killed.

Edit: I forgot to mention the licensing system is the same, you still need a FlexLM server running, you can generate your own license files in the AWS account.

1 Like

If we do this , what happens to the old repository? Can we just stop the current render farm, install the latest version on a linux box and point it to the existing repository and then move other components (like the ones in here Relocating the Database or Repository — Deadline documentation ) and it should work?

Also, if we do this, what happens to the license? the new deadline doesnt seem to need any licensing

Yes, you install the repo & database on the new server, when prompted you point back to the old repo to transfer over the info (passwords don’t get copied, some other stuff too)

Then you can decommission the old server, probably best to check everything is working as expected before wiping etc.

The license is still required, but you can now generate you own via AWS, doesn’t look like it’s working ATM

OK. So just attempting to upgrade from 10.0.23 to I ran into a major issues to complete the process. I ran the installer and it proceeded and then hung at the last step and just sat there. I left it for over 30 minutes but it didnt progress or go any further than that. Is this a known issue for the latest version of deadline that was mentioned before?

I get this, quite often on old repos with lots of data. Not sure where it’s hanging, whether it’s trying to pull all statistics or all old job reports. I found if I cancel it the repo works and reports the new version. Not found any issues with it.

You could have skipped this issue by installing a fresh version on the new server along with the latest database, then importing the settings from the old server.

1 Like

So a few things:

  • When its stuck like this, is it actually changing anything on the repo? I was afraid of stopping it incase it was actually making changes to the repo. so when I stopped the install, i also had to restore the repo to before I made any changes because I noticed some stuff was actually changes
  • I was afraid that if skipped this and installed on a fresh server, that I would face the same issue because if this is a wierd bug in the installer or something in the repo.
  • I also noticed that in our repository, in the reports folder, there are job reports in there that do not exist in the deadline monitor when we search it. What could be causing this? how do we clean these reports up? Our reports folder in the repository has alot of files (almost a million).
Privacy | Site terms | Cookie preferences