Worker startup error

Hi, I’m currently having an issue when launching a Worker on one of my machines. I get this error message:

Traceback (most recent call last):

File “UI/Forms/”, line 177, in Startup
File “UI/Forms/”, line 236, in ConnectToRepository
InvalidOperationException: Failed to retrieve the secret (/admin/ublsettings/UsageBasedURL) due to an unexpected error. Please see Server’s application log for further information.
at Deadline.Controllers.RemoteSecretsManagementController.GetSecret(String secretId)
at Deadline.Controllers.UBLSecretRetriever.a(DataController dks, String dkt)
at Deadline.Controllers.UBLSecretRetriever.GetUsageBasedURL(DataController dataController, DeadlineNetworkSettings networkSettings)
at Deadline.Configuration.Plugins.PluginManager.e()
at Deadline.Configuration.Plugins.PluginManager.f(LicenseMode dmu, Boolean dmv, Boolean dmw)
at Deadline.Configuration.Plugins.PluginManager.ConfirmPlugin(Boolean useLicense)
at Deadline.Configuration.Plugins.PluginManager…ctor()
at Deadline.Configuration.Plugins.PluginManager.GetInstance()
at Deadline.Slaves.SlaveManager.Connect(RepositoryConnectionSettings connectionSettings, Boolean updateScriptManager)
at Deadline.Applications.DeadlineApplicationManager.Connect(Boolean updateScriptManager)
at Deadline.Applications.DeadlineApplicationManager.Connect()

And in the Monitor Console:
2021-04-07 12:22:04: Traceback (most recent call last):
2021-04-07 12:22:04: File “C:\thinkbox-conda\conda-bld\deadline_1604521343884\work\DeadlineProject\DeadlineUI\Models\”, line 374, in onItemUpdated
2021-04-07 12:22:04: AttributeError: type object ‘RemoveToken’ has no attribute ‘Info’

Possibly related, an entry (I’m assuming this machine) keeps appearing in the repository as “Unknown” when I run the Monitor (but Worker has NOT been launched) unknown


Could you check your Remote Connection Server’s log for an error when that machine comes online?

That’s an error from Secrets Management. My usual guess is that you’ve not granted that machine the “Client” role in the Monitor under Tools → Manage Identities. So I’d check that as well.

Privacy | Site terms | Cookie preferences