3ds Max 2020 "faulty" submission

Sorry for the title but I couldn’t come up with something more descriptive…
I have an animation file created in 3ds Max 2020 and rendered in V-Ray Next 3.1, like all other files in the project. There’s absolutely nothing special about this file on how it was created and what it contains. In fact, I submitted the same file at least twice to Deadline: one for a test render, one for a final render; then after a few months, I opened it again, tweaked a couple of things, and submitted it again.
And this is when problems started.

The file links to XRef objects, which are moved by animating Helpers; the output is a PNG file, and an EXR file with a two render elements (MultiMatte and Denoiser). Again, this is standard across all my files.

I submit to Deadline via the SMTD, sanity check returns two amber errors: render element output filename is undefined; the scene is however submitted and appears in the Monitor.
If I check the render elements they are still there but the path has been stripped (I have the “rebuild render elements” option on, so I would still see the output path after a submission).
When the scene is rendered, no XRef files are loaded and no error is given by either 3ds Max or Deadline. Files are saved and the EXR contains all necessary layers (RGBA, effectResult, MultiMatte, and the Denoiser group), showing only the sky map used as background.

I tried removing the render elements, adding them again, disabling the V-Ray buffer, force separate render channels in V-Ray options, but no success.
If I render the file locally, I don’t get any errors.
This is the only file with this problem, and I can’t quite understand what’s going on.

Deadline log is attached.

SubmitMaxToDeadline - [W200122] - 06-10-2020-0006.zip (4.8 KB)

It does look like there are a couple of empty outputs in that submission, double check that you’re not overriding output directories in the submitter with empty paths. It’s possible there’s a sticky setting from another submission causing trouble here.

Since XRefs are involved here, and the submission does not tell us much about where their source files are and how the Deadline Worker is handling them, looking closer at those components would be a good idea.

From the submission log I can see that SMTDSettings.IgnoreMissingXREFs = true, which means that if the XRef file the object are referenced from is located on the local machine, but the Job is rendered on a machine that cannot access those XRefs, the Job will NOT fail (because it is set to ignore missing XRefs), resulting in exactly the output you described.

So the things to try would be:

  • Disable the option to Ignore Missing XRefs, resubmit the job, and see if it will fail with an error about missing XRefs. If yes, ensure the render node can see the source file of the XRef Object, for example by using a shared network path (e.g. a NAS drive that contains all assets)
  • Check the option to merge XRef Objects before submission (Render tab > Scene Tweaks rollout > Merge Object XRefs checkbox) - this should make the XRefs part of the submitted scene, solving issues with XRef files located on a local drive not accessible to network render nodes.
  • While it would be possible to enable the option to collect and submit local external assets with the job, it is the “nuclear option” in SMTD and I don’t recommend it.

In short, make sure the scene files where the XRef objects are coming from can be seen by the render nodes, or that the XRef objects are part of the submission. It is possible that previously you had some of these options enabled which made the scene function properly? Or the XRef source files were previously located on a network share?

My impression is that this is a MAX setup issue, and Deadline is simply ignoring the error because you told it to. But I could be wrong. :slight_smile:

Hi Bobo,
thanks for the reply. The Deadline settings are saved in a preset I use for all scenes in the project (400+ and counting), and all files use the same 3ds Max setup.

This is the only scene that I have problems with, and I previously submitted it without any problems; I had to tweak the lighting a bit and after that Deadline started to report errors with the render elements.

The scene is fine, 3ds Max doesn’t give any errors if I open it “manually” on any machine I render on; XRefs, maps, and any associated files are in the correct location and are correctly loaded by all other scenes. Rendering from 3ds Max doesn’t produce any errors either.

I have this hunch that the XRef error at render time is somehow created by the STMD and its inability to correctly interpret render elements, which are the two amber errors I get during submission.
What could cause Deadline to not being able to interpret/rebuild render elements correctly?

I don’t think the render elements are involved in the Object XRefs issues.
The two warning messages you are getting mean that two Render Elements have no output filename. This can be totally OK if you are outputting them to EXR layers via the V-Ray Framebuffer. If you want, you can define explicit output filenames for these Render Elements to get rid of the warnings, I assume the paths won’t be utilized anyway if V-Ray is using the Render Elements to output to EXR.

What I want you to do (but maybe did not state it forcefully enough in my previous post) is DISABLE the option to “Ignore Missing XRefs”. Then submit the job, and look at the render log - I would expect an error to be printed to the Workers log. If you get that, it means the XRef cannot be loaded, period.

Remember that loading the scene on the render node in Workstation mode in 3ds Max might NOT match exactly what the behavior is under the Deadline Worker.
First, the Deadline Worker might be running under a different user (for example if the Launcher is installed as a service), so drive mapping can be different - if any XRef files are stored on a network share with a mapped drive, that path could be not defined in the Worker even when it is mapped for your logged in user.
Second, Deadline runs 3ds Max in network rendering license-free mode (Backburner-mode, basically). So if you would talk to our Support team, they would ask you to execute the actual command line that Deadline Worker reports in the log, from a command window.

Solved!
A bit of a PEBKAC, a bit of software doing stuff they are not supposed to do.

First I tried to merge things in a new scene, and everything worked fine in the new file.

Then as you asked I turned on the missing XRef flag in the “faulty” scene, which made me remember that in the preset I’m using it should be already on…of course the render would fail with “The Object XRef file can not be found”.

So I checked the logs of a successful job, and searched for the path to the MXP file I submit with the task; said path is not present in the “faulty” file’s log.

In 3ds Max, I open the “faulty” file: the SMTD shows the preset name I am supposed to use, but the options are Deadline’s default. I re-select the preset from the dropdown list, hit “load preset”, then “submit”, and…submission is without problems and the scene renders without any problems.

Somewhere between the old successful submission and the new unsuccessful one, either Max or Deadline reset submission options to default instead of using the preset, and Deadline SMTD showing the preset name made me think it was loaded and active.

But now all’s well. Thank you for the support.

Privacy | Site terms | Cookie preferences