3Ds max BlowUp Region has offset

Hi,

When displaying the blowUp region in the SMTD_MainRollout with checking the ‘Show Region Gizmo’ it has an offset. Unfortunately it also renders this offset when submitting so I have to adjust this every time before I do an submission.

This also occurs in older 3ds max version on my desktop. But it turns out it does work properly on other desktops with the same version 3ds max and version of Deadline…

This is the result after pressing ‘Update Region Values’ in a clean file:

  • My 3ds max units are the same as on the working desktop
  • It happens to all my 3ds max files
  • In all my viewports ( perspective, front, cameras… )

Which variable could cause this offset?

Meanwhile my temporary solution: If I add to all region coordinates [ left, right, width, height ] approximately 11% it will be close to accurate but far from ideal.

Thanks!

Nobody any idea, suggestions, clue upon which (windows) variables it could depend on? … :pensive:

what is your Deadline version and max version?

Deadline 10.1 and 3Ds max 2019.3 Update.

It’s weird that other colleagues using the same versions and they do not have this offset…

my SMTD does not even look same as yours…
Deadline 10.1.9.2 (look the same for me in 2dsMAX 2020 and 2021)
Annotation 2020-08-03 163407

Edit : Ho ok, forgot to switch the tiles & region rendering option …my bad…

Have to try to “Rename” 3dsMAX “ENU” folder to “_ENU”, and check if it’s a 3dsMAX user preferences issue?

Yes, I did rename the ENU. I also tried:
Running 3ds max as admin
Changed the ‘Custumize Format’ variables in windows metric system
change in the display settings the ‘Scale and layout’ size percentage

Unfortunately all of these tries with no different outcome in the offset :frowning:

Edit: Ah Maybe a small step closer… Another user logged in on my desktop and it turns out there is no offset anymore… So seems to be that it is user dependent… Still no clue though what to try and suggestions are welcome :slight_smile:

Ok, it seems to be that the issue is in 3ds max…

If I use the following settings I would expect the region would be inside the viewport boundaries and it doesn’t. Somehow this conversion goes wrong and is strangely enough user dependent.

I also posted it now on the autodesk forum, fingers crossed for a proper solution :wink:

what about with this script (build quickly mostly for 2x2 blowup)
the Auto feature…
Blowup Tool.zip (25.1 KB)

This script also contains this offset. I have to push the resolution 25% to make it work or decrease the blow up variables 20% to make the logic work. Pretty strange.

It seems like I did tweak a variable that influenced the offset because it became even worse. But can’t recall which variable this was… It’s now not 11% anymore but like 25% I have to add. A better number to recall though :stuck_out_tongue:

Hmm… no clue what happened, but for some reason the offset is gone… So somewhere I am happy but frustrated I do not know why and when it could appear again… Anyway, Thanks for your input MarcoA :wink:

1 Like
Privacy | Site terms | Cookie preferences