AWS Thinkbox Discussion Forums

3dsmax 2024 Support

For those wondering, I’ve put a ticket in the Thinkbox queue… but no eta… but if you’re wanting lightning rebuilt for 3dsmax 2024, submit your own ticket as this helps add pressure on.


Oh! ok,

I came here searching for Deadline update as everything else I needed to be able to use 3DsMax 2024 already came out.
The only missing piece is Deadline now!

I’ve heard from the engineering team that we’ve got something internally you can try. We’ll see about getting a build up to the forums here.

1 Like

Hello @Dave_Wortley

I am attaching the patch for 3dsmax 2024 here, please test and let me know if it works. It is unofficial patch which includes UI support, it should work as expected, it may not work with new features which may have been introduced in 2024 version. Once the full support is released (cannot share an ETA) please upgrade. Creating backup is important here.

Backup and replace the following:

  1. [Repo]\plugins\3dsMax\
  2. [Repo]\plugins\3dsMax\3dsMax.param
  3. [Repo]\scripts\Submission\

3dsmax2024files.tar (253 KB) (47.1 KB)

Add new folder in [Repo]\maxStartup\2024 and put the contents of this archive in there. (167.6 KB)

To submit from within 3ds Max the installers aren’t available yet, please install it manually by following here: 3ds Max — Deadline documentation


I get this error after patch? NameError : name ‘unicode’ is not defined
Any sugestions? Thanks

I have the same error. Isn’t there a better way?

@mi-kan-kun where are you seeing this error, Is it at submission time or render time?

Can you share some logs or screenshot where are your seeing this error. If you are seeing at the render tim, you can get the job reports following this documentation: (Logs — Deadline documentation)

And if this Name error on Unicode is occuring at submission time, could you be able to share the maxscript listener and the SMTD logs

Thank you for your reply. I’m encountering an error during rendering. I will send you the log.


NameError : name ‘unicode’ is not defined



Stack Trace

at Deadline.Plugins.SandboxedPlugin.d(DeadlineMessage bed, CancellationToken bee)
at Deadline.Plugins.SandboxedPlugin.Initialize(Job job, CancellationToken cancellationToken)
at Deadline.Slaves.SlaveRenderThread.e(String aix, Job aiy, CancellationToken aiz)
at Deadline.Slaves.SlaveRenderThread.b(TaskLogWriter ait, CancellationToken aiu)


2023-05-17 09:38:54: 0: Loading Job’s Plugin timeout is Disabled
2023-05-17 09:38:54: 0: SandboxedPlugin: Render Job As User disabled, running as current user ‘user’
2023-05-17 09:38:57: 0: nogui was not added to the CommandLineParser.
2023-05-17 09:38:57: 0: Executing plugin command of type ‘Initialize Plugin’
2023-05-17 09:38:57: 0: INFO: Executing plugin script ‘C:\ProgramData\Thinkbox\Deadline10\workers\user\plugins\646422070bc24ec9402d0d29\’
2023-05-17 09:38:57: 0: Encountered an error while executing plugin command of type ‘Initialize Plugin’

Yes during rendering when worker trying to launch max.

Thanks for the reports everyone. The support team had a quick meeting about this and we’re wondering if it’s related to the version of Python Deadline might be loading since we have Py2 and Py3 these days.

Some questions:

  1. What vesion are you on if it’s failing?
  2. Is this working for anyone? @Dave_Wortley did you have positive results?

For those on a version of Deadline before can you upgrade? We also default to Python3 in 10.1.20 and that may also be helpful.

Working normally here on Max 2024.1 and Deadline With an initial Max service pack out and Redshift support having just released, I’ll be moving my production over to the new version as long as Deadline keeps working. Thanks to the team working on this.

The version was 10.1.16
After updating to it worked fine.
thank you not working, Iľl try to update but its not that simple for us ;/

Any idea when there will be official support? We’re just sitting waiting on this before we can upgrade the office

Eagerly awaiting an official update at our studio too.
Tried the workaround but upon submission received errors: ‘FailRenderException’ and ‘(Python.Runtime.PythonException)’

Yes personaly I would prefer official support too because if I force whole company to update now and then after a month (who knows?) again nobody will like me :smiley:

Update: after updating to the latest official Deadline release (I was mistaken thinking we were already up to date) and then following the workaround instructions through again as above, it all appears to be working! Havent attempted rendering and scene with 2024 specific features yet though.

Thanks for reporting everyone!

Good/bad to know the folks waiting on the official release (thanks for that). For what it’s worth, this particular bundle is sneakily what we intend to be shipping. I’m deeply appreciative that you folks have been so responsive on this.

Work perfectly fine with…

… I’m also waiting for the final release, as I have to do the deployment myself and is always troublesome and time consuming, I would like to do it just once :slight_smile:

Hope we can get it soon!
And wonder if for next releases we can have the Thinkbox guys prepare the version ahead of the 3DsMax release… that would be awesome.

1 Like
Privacy | Site terms | Cookie preferences