Animated Magma parameters don't show up in the Graph editor


#1

Hi,

I have another Krakatoa for Maya question coming from a 3DS Max background…

I have a few Magma flows set up on prt loader objects in Maya and I have animated some parameters to affect the density, emission etc over time. But when I select a prt loader object and try to view the animation curves in the Graph Editor I see the prt loader object but I don’t see anything showing up for the Magma flow and so I don’t see any way of editing (or even viewing) my keyframes. I’ve tried selecting Show - All and checking that all attributes are displayed but still nothing shows up for the Magma flow in the Graph editor. I must be missing something, right? Surely it is possible in Maya to edit any keyframes that I set in a Magma flow?


#2

No help on this?? I still can’t see my keyframes in the graph editor and this will be a big problem for me in production if I cannot find a solution.


#3

Hi Jim,
I was able to reproduce what you were seeing. I was also able to get Magma attributes to show up in the Graph Editor. However, my solution is a little strange.

As it turns out, when you open the Graph Editor, it will only operate on the currently selected object. So, in your case, it will be displaying only the animated attributes from the PRTLoader. However, this is actually not what we want, because we want to show the animated attributes from the PRTMagma object that is connected to the PRTLoader. It will have a name like “PRTMagma1”. Try these steps:

Create a test scene:
-Create new scene
-Create PRTFractals (or PRTLoader)
-Create Magma on that Fractals/Loader
-In the Magma editor, create an input “Float” node.
-Add some animation to its float value.

Open Curve Editor to the Magma node:
-Open up the Script Editor, and type this in as a MEL script:
select -r PRTMagma1;
-Run the script (Command > Execute)
-Finally, open the Graph Editor. It should work (you should see your animated curve in there properly)

So as long as the “PRTMagma” node is the current selection, it seems to work. But for some reason, Maya doesn’t seem to want to change the selection to the Magma node directly through the UI. You can’t just click on the PRTMagma tab in the Attribute Editor. Maybe there’s some way to do this, but I am unaware of how at the moment.

Do the above steps work?


#4

Hi Conrad, thanks for your reply. I thought that having the Magma node selected was part of the issue and I was trying to get that to work before.

I tried your script and it works in that it selects the Magma attribute but it doesn’t work in having any keys show up in the graph editor. I tried this in a new scene as well with the same technique it it still won’t work.

There has to be a solution for this, right?


#5

Ok. I got it to work… Turns out you don’t need MEL script or anything. See my screen shot for how I got it to work. Maya is weird.

[attachment=0]magma_animation.png[/attachment]

Do those steps work?


#6

Hi Conrad, thanks again for your help. The steps you outlined make sense to me but unfortunately it still doesn’t work on my end.

One thing that is interesting is that in the Graph Editor if I go to Show - Select Attributes - it lists the animated values in the Magma flow so it seems to recognize the animation that is there… but the curves still won’t display in the graph editor. I’m starting to wonder if the version of Maya we have in the office is buggy or if I should just make the case to my boss to let me use 3DS Max instead… I have to leave the office in a few minutes but I’ll try more troubleshooting in the morning.

Haha, I’m glad you agree that Maya is weird :stuck_out_tongue:


#7

Minor update: If I have the Magma attribute selected I can see the keys in the Dope Sheet but still no curves show up in the Graph editor.

I have also started to look online to try and find any relevant MEL scripts that will force the Graph editor to display the animation curves of a selected object. I don’t really have any experience writing MEL scripts so I’m not sure how to create this from scratch.


#8

Had this problem recently, this is how I remember getting the curves:

Go to the magma node that is animated in the Magma window, the attribute will be red. Right click in the attribute field and select the top most item, it should be the animation curve node. When you select it it will load into the Attribute Editor and you can edit the keyframes spreadsheet style. If you hit the select button at the bottom of the Attribute Editor it will load into the Graph Editor.


#9

Hey Rebus, thanks for your post. I tried what you said and I can at least see the Anim Curve Attributes spreadsheet view with the keys listed. This helps but it still won’t let me view the curves in the Graph Editor. I do try hitting the “Select” button at the bottom of the Attribute Editor when I have the PRT Magma selected like you said but it still won’t show the curves in the Graph Editor.


#10

Maybe we can do a remote session this week and I can take a look at what you’re seeing. I know it’s possible, because I am able to do it on my computer. Perhaps we can get it working still.


#11

Thanks Conrad, sure I can do a remote session this week. I am in the office from 9 am - 6 pm PST so please let me know what time works best for you.

Thanks again!


#12

Meanwhile you might want to check the settings on your Graph Editor panel. Maybe it is something there: like auto load selected objects (under List menu) being unchecked. The Show menu isolates what is listed by type, so maybe something there is checked?

Once you have the animation curve object in the attribute editor it should definitely load into the graph editor on selecting… no longer a Krakatoa issue at that point since the animation curve node is a Maya object.

Good luck!


#13

Hi Conrad, I don’t know if you saw it yet but I responded to the help ticket for this issue. Unfortunately my trial version of Krakatoa for Maya expired today so I cannot do anymore testing at the moment.

At this point I am really considering trying out the trial version of Krakatoa for 3DS Max to see if that works better. I have to do some tests here to make sure it works OK with our setup here before purchasing a full version. I have much more experience using Krakatoa for 3DS Max so maybe I’ll just go with that. :confused:


#14

Thanks for the help Rebus, I’ll try that next!

Maya, WTF!?


#15

A common refrain for us Maya TDs!