Animation codec?


#1

I need to render out an Animation codec quicktime but it doesn’t look like that is one of the valid codecs from the cookbook page.

viewtopic.php?f=179&t=10649

I put the codec into a custom template but it didn’t render I guess this is true. But is there another way to get the Animation codec?


#2

Correct, Draft does not support the Quicktime Animation codec at this time. I’ll add this to our wishlist.


#3

Just out of curiosity, why wasn’t the Animation codec included?

Also, on a separate but somewhat related question. I was attempting to run a DNxHD draft job. But I got the following error:

2014-07-22 14:02:29: 0: STDOUT: RuntimeError: Unable to acquire Draft Pro Codec license, which is required to encode DNxHD video for file: X:\Optimus\Clients\Bristol_Myers_Squibb\CTLA4_MOP_14_3363\Animation\compositions\BRICT_02\Draft\BRICT_02_v001_JB.mov 2014-07-22 14:02:29: 0: STDOUT: No such feature exists. 2014-07-22 14:02:29: 0: STDOUT: Feature: draft-pro-codec 2014-07-22 14:02:29: 0: STDOUT: License path: @squidnet; 2014-07-22 14:02:29: 0: STDOUT: FLEXnet Licensing error:-5,412 2014-07-22 14:02:29: 0: STDOUT: For further information, refer to the FLEXnet Licensing documentation, 2014-07-22 14:02:29: 0: STDOUT: available at "www.flexerasoftware.com".

I downloaded and installed the Draft Pro codec onto a few test machines but I still got the same error. Is there something else that I have to do to get this to work? I thought the DNxHD codec was free.

Thanks

James


#4

Animation codec: Given that this is an Apple codec, I believe we’d need to negotiate licensing with them. We’re still working on ProRes. I can ask Chris to ask about the animation codec while he’s at it.

Were you wanting to use the alpha channel in the animation codec? That would require some changes in our code, in addition to negotiating the license.

DNxHD: When you say you “downloaded and installed the Draft Pro codec”, are you referring to a pro license from sales? Or something else? In order to include DNxHD in a commercial product, we have to pay a per-license fee, and so we charge for that version of the Draft licence. If you are interested in using DNxHD, please contact Sales: thinkboxsoftware.com/sales-contact/


#5

Animation codec isnt an Apple codec.


#6

also - another thread

viewtopic.php?f=127&t=10110&p=48218&hilit=animation+codec#p48218

we have rawvideo, but not animation.

cb


#7

To andrea.mantler:
I pretty much did a Google search for “DNxHD download” and I found this link:

community.avid.com/forums/t/83533.aspx

Which led me to a download. I was honestly making a shot in the dark.
I’m looking for the Animation codec because that’s what our compositors pass along to our editors. I’m honestly just looking for any codec which provides a lossless container that I can render on our farm through Deadline. Given the fact that we can only render quicktimes out of Nuke to a local file path, I was hoping Draft would allow us to render on the farm and send the file to a location on our network.

To cbond:
As for Animation not being an Apple codec, are you sure that’s true?

en.wikipedia.org/wiki/QuickTime_Animation

And I can’t access that thread you linked,


#8

Yeah Animation at Max Quality is equivalent to a Targa with RLE compression.

The four codecs we use are:
H264
Animation
DNxHD
ProRes

Honestly all of these problems could be circumvented if you implemented the Quicktime encoding engine like Nuke, REDCine, Max etc. Then you can simply use any Quicktime compatible codec and leave the licensing up to us.


#9

So I wanted to bring this up again because this is becoming a bigger issue at our studio. The fact that we have to render quicktime movies locally rather than putting them on our farm is a huge time suck. Could someone at least explain why I can’t run a Nuke job writing out a quicktime file on our farm using Deadline? If there is a way around this (purchasing a license?) we would be interested in pursuing it.

Thanks!


#10

I’ve talked to Ian, and I’ll be looking into whether adding the Animation codec will be possible for the current Draft beta cycle. I’ve asked Jon to answer your Deadline question.


#11

Could you elaborate on what the problem is? There shouldn’t be anything stopping you from submitting Nuke jobs that render out Quicktimes to Deadline…

What kind of errors are you getting when you try to do this?


#12

OK so here is text from an error log and a screen grab of an error window that pops up on the machine trying to render the nuke scene. We actually have a Quicktime Pro license so I installed it on this machine in hopes that it would solve this issue, but it didn’t. When I submit the render it will hang for a long time. If I remote into the render machine I see that error window pop up. If I close that another one pops up immediately and an error log is written in Deadline.
Nuke_QT_Pic.jpg
Nuke_QT.txt (5.55 KB)


#13

Are you rendering to a network UNC path or a local drive? I think even through Nuke Quicktime won’t render to a remote path and you have to render locally and then move it as a post process.


#14

Hmmm, seems like the QT plugin for nuke is trying to find .NET 1.1 and failing… Try installing the .NET 1.1 runtime (which contains MSCVR71.dll) on that Slave and see if it fixes it:
microsoft.com/en-us/download … aspx?id=26


#15

Gavin - Yes, we are using network UNC paths. So this is what I’m trying to confirm. I’ve seen allusions to this fact that Nuke won’t render quicktime files to non-local paths ( I think we have this issue with After Effects as well).

Jon - Thanks, I’ll give that a try ASAP.


#16

The .NET 1.1 did not work. :frowning:


#17

Did you try saving the video to a local (to the slave) directory, and then use a post-process to move it where you want it?

Scratch that… the dll error probably doesn’t have anything to do with paths. (This is why I stick to answering Draft questions…)


#18

This is the error I get when I try to render a Quicktime to a remote location:

[code]---------------------------
Nuke

Write1: Couldn’t open file


OK Hide Details…

[/code]


#19

Yup, that’s the same error I get when I render from within Nuke.


#20

Have you figured out how to run Nuke through deadline at all, or are you still getting the dll error?