C4D x Octane error in EndJob


#1

Hi !
We have an issue running Cinema4D R19 job with Octane 4. Everything is working fine except that at the end of the job the ‘shutting down Cinema 4D batch plugin’ throw an error and hold the octane license. The only way to recover the license is start/stop C4D manually / gui way. Here’s the error :

2019-03-14 15:12:49:  0: INFO: Script Ran Successfully
2019-03-14 15:12:49:  0: INFO: Finished Cinema 4D Task
2019-03-14 15:12:49:  0: Done executing plugin command of type 'Render Task'
2019-03-14 15:13:03:  0: Executing plugin command of type 'End Job'
2019-03-14 15:13:03:  0: INFO: End Job called - shutting down Cinema 4D Batch plugin
2019-03-14 15:13:03:  0: INFO: Sending End Job
2019-03-14 15:13:03:  0: Done executing plugin command of type 'End Job'
2019-03-14 15:13:03:  0: Error in EndJob: Error: timed out while waiting for data
2019-03-14 15:13:03:     at FranticX.Net.SocketUtils.RecvMessage(NetworkStream networkStream, Int32 timeoutMilliseconds)
2019-03-14 15:13:03:     at FranticX.Net.ListeningSocket.Receive(Int32 timeoutMilliseconds)
2019-03-14 15:13:03:     at Python.Runtime.Dispatcher.TrueDispatch(ArrayList args)
2019-03-14 15:13:03:     at Python.Runtime.Dispatcher.Dispatch(ArrayList args)
2019-03-14 15:13:03:     at Deadline.Plugins.DeadlinePlugin.EndJob()
2019-03-14 15:13:03:     at Deadline.Plugins.DeadlinePlugin.DoEndJob()
2019-03-14 15:13:03:     at Deadline.Plugins.PluginWrapper.EndJob(String& outMessage, AbortLevel& abortLevel)

If I run the same job cmd way with

“C:\Program Files\MAXON\CINEMA 4D R19\Commandline.exe” -nogui -render S:\BENCH\c4D_TEST.c4d

everything works and I get the license back.

Any clues about this would be appreciate.

Best

P.


#2

A workaround should be turn off batch rendering. I’m curious if there’s an error when Cinema’s shutting down.

Offically we don’t support Octane 4 just yet (standalone specifically). If it’s pausing Cinema on shut down we could try and increase the timeout. It looks like it’s currently only eight seconds:

    ProgressUpdateTimeout = 8000

Would you be willing to bump it up to 60000? It’s in “[repo]\plugins\Cinema4DBatch\Cinema4DBatch.py”. I’m wondering if that’s all that we’d need.

There’s an option in the “Plugin configuration”:


#3

Ok, turn off batch rendering definitely solve the issue : Licence is not lock anymore and no more error in the log

2019-03-19 18:01:22:  0: STDOUT: Rendering Phase: Finalize
2019-03-19 18:01:22:  0: STDOUT: Rendering successful: 21.123 sec.
2019-03-19 18:01:24:  0: INFO: Process exit code: 0
2019-03-19 18:01:24:  0: INFO: Finished Cinema 4D Task
2019-03-19 18:01:24:  0: Done executing plugin command of type 'Render Task'
2019-03-19 18:01:27:  0: Executing plugin command of type 'End Job'
2019-03-19 18:01:27:  0: Done executing plugin command of type 'End Job'

Regarding the batch rendering way, I also tried to modify Cinema4DBatch.py by increasing ProgressUpdateTimeout or countdown value in EndCinema4DJob fonction but End Job doesn’t seem to respect this modification : the error ‘timed out while waiting for data’ still pop up almost immediatly after calling End Job. I don’t know where to investigate now…

That’s annoying, even if the time loose by reloading C4D between each task (10-15 secondes) isn’t significant regarding processing time, this option sounded really promising !


#4

Actually, re-reading the code you must change it in the user interface there. The initial call is overridden by the plugin default so the UI is the way to go on this one.

I’m glad there’s a workaround temporarily though. I’m just hoping that increasing the timeout is the better way to go.