AWS Thinkbox Discussion Forums

Channel Gradient renders in editor, but not in picture viewe


a couple of questions:

I portioned some x-particles and got them back via the PRT Loader.
Now I’m trying to map a gradient over the position channel, which is listed as available.
It’s correctly displayed in the editor view, but when I try to render it through the picture viewer an error pops up:
Channel “Position” does not exist in source stream.

I’m pretty sure I missed something simple here. Any help appreciated.

You have discovered a bug in the Gradient tag.

Some of your frames in your sequence have 0 particles, so there is in fact no Position channel in the PRT Loader on those frames.
When the sequence has 0 particles, the Gradient should not fail with an error message about a missing channel, but ignore the stream and not apply (since there are no particles anyway).

In Krakatoa MX for example, in these cases one could set the Use Custom Range to the actual frames where data exists, and prevent such errors. In theory, Krakatoa C4D should be doing the same, even if the Range Start Mode is set to “Blank” instead of “Hold First”. Obviously, it does not behave like that, it throws an error and makes it impossible to render frames with 0 particles.

Currently your only workaround would be to set the Use Custom Range to checked, the Range Start to the first frame with more than 0 particles, the Range End to the last frame in the sequence, and the Range Start Mode to “Hold First”. Unfortunately, this means that if there are many particles on the first non-zero particles frame, they will be rendered on all previous frames. If there is only one particle, it might not be very obvious. :wink:

I will log this as a bug and we will try to fix this ASAP.
Thank you for your patience and sorry for the inconvenience!

Thanks for the fast reply, Bobo!
Using the Range Start Mode did the trick for me. Great explanation what caused the problem! I was close to crazy.

Privacy | Site terms | Cookie preferences