Could not connect to Deadline Repository

Hello all, I’m new to Deadline, and I have an issue when I start Deadline Slave trying to connect to my other main machine where I installed my Deadline Repository, I’m getting a message says that:

"Could Not Connect to Deadline Repository
Failed to establish connection to “machine IP”:4433 due to communication error.

Deadline Slave will try to connect again in 10 seconds…"

Pls. help,
Thank you

Looks like you’re trying to connect using the Remote Connection Server (just based on that port number). Is the RCS running on the machine you’re trying to connect to?

If it is, is the Worker machine that’s failing to connect able to ping the other machine’s IP address?

I’m not sure if I understand your question very well about RCS running on the machine I’m trying to connect to, but to explain more Pls. note the following:

  • I have installed both the “DeadlineRepository.exe” & “DeadlineClient.exe” on my main machine (PC) with RCS certificates on my main machine.

  • I then installed only “DeadlineClient.exe” on my slave machine (PC) with RCS certificates on my slave machine.

  • then I started “DeadlineClient” on my main machine and connected directly to DeadlineRepository which is on my main machine.

  • then I started “DeadlineClient” on my slave machine and tried to connect using Remote Connection Server to DeadlineRepository which is on my main machine, but I receive the failure to connect message:
    “Could Not Connect to Deadline Repository
    Failed to establish connection to “machine IP”:4433 due to communication error.
    Deadline Slave will try to connect again in 10 seconds…”

  • I disabled my firewall and antivirus on my both machines (my main machine and my slave machine) and tried to connect again but same it is not connecting…

I don’t know what is the issue here.

Pls. help,
Thank you

On the computer you’ve installed the Repository on, if you right click on the Launcher tray icon there’s an option to Launch the Remote Connection server. That way the machine you’ve installed the Worker on will be able to connect.

Are both machines on the same local network? It’s probably simpler for you to use the Direct Connection setting on the Worker machine instead of getting the Remote Connection Server to work.

To do that, in the Select Repository window that should be appearing after the connection fails change the option at the top to Direct Connection. Then fill in the Repository Path. You’ll need to make sure that the DeadlineRepository10 folder is accessible by the Worker machine.

Oh you mean that in order to connect from my Worker (Slave) machine using Remote Connection server I have to launch the option Remote Connection server on my main machine where the Repository is installed… OK then let me try and get back to you.

Yes both machines in the same local network.

for the Direct Connection of my worker (Slave ) machine to Repository on my main machine, I didn’t know that I can do it this way, however, let me try both ways and I will have to share my Repository folder on the network as I know for other machines on on the network to be able to find it and access it. I’m just worried to share my Repository folder over the network to avoid any unauthorized access and messing with the content of this folder by unknown people.

Let me try and get back to you, thank you so much for your care and support.

1 Like

Hello, I have uninstalled the old version of deadline and reinstalled the latest version on my main machine, actually there are a lot of issues with deadline some of these issues are:

  1. I’m using sketchup + vray for modelling and rendering and I have installed the submitter for sketchup and tried to use deadline with sketchup here’s what I get:
    a) after submitting job to deadline using the “submit to deadline” option , in the submission window I chose 2d image and type .png for the output, then if I deselect the option “use vray” and I selected the option “transparent” which should result in .png image with transparent background then the render output will be a png. image but not transparent !! the background will be just a light gray color, and if I selected the option “use vray” then the sketchup software will keep restarting and rendering then crash then restart again and render and crash and so forth… the render output will be a .png image with white background (Not transparent as it should be when using the normal vray render window inside sketchup) … and also the resulted png image will be corrupted… I don’t know why this is hapenining…
  2. after restarting my pc then the command prompt window for deadlinercs.exe starts automatically and keep restarting without ending… I tried to close the cmd window several time but keep restating automatically… I don’t know why even though the type of connection I chose for my deadline worker is “direct connection” not using a remote connection server so I don’t know why this is happening…!!

conclusion: this software Thinkbox Deadline is so complicated and there is no single tutorial video shows how to use it with sketchup and vray for distributed render … I couldn’t get it to work smoothly so far…

if there is any help from the developer or experts here I would appreciate a suuport.

Thank you,

I’ll stick with your numbers here so we don’t get mixed up.

  1. To diagnose why the image isn’t being rendered properly we’ll need to separate Deadline from Sketchup by running the render with the same commands that the Worker runs to see if there’s an issue in the flags we’re passing it. We’ve got a Troubleshooting Guide for exactly that.
    As for the crashing with VRay enabled, check the crash logs. To find those enter %temp% in File Explorer and you should be able to find them.

  2. It sounds like you’ve got the RCS configured to stay running. Disabling that isn’t the most obvious as it’s controlled by the client config file. Find yours and make sure that keepremoteconnectionserverrunning is set to False.

Let me know what you get!