Deadline-10.1.12 Install Issue

Hi there,

Just got a trial for Deadline and I’m superstoked to get it going, I’ve used it at work quite a bit.

My issue now is that I am having trouble with the install.
I’m on Ubuntu 20.04 LTS and saw a recent post here that the MongoDB install that the Deadline installer tries to invoke doesn’t work.

So I’ve manually installed MongoDB and have it up and running, all ports and ip/DNS settings correct (I checked the logs to be thorough)

But when I run the installer and tell it to look for an existing install I am met with this error message (after giving it the server,port and database name):

“Error: There has been an error.
An error occurred while trying to update database settings in the repository.
Press [Enter] to continue:”

Any and all help as to what could cause this would be most appreciated.

I am no experienced sysadmin so I’m just digging around best I can, but all folders/paths have been fully opened to make sure there are no permission conflicts.

Thanks a ton,
Jack

Hi Jack,

I’ve just tried to install the 10.1.12.1 on a fresh Ubuntu VM and it is giving me the same error.

Looking at the bitrock_installer.log in /tmp, it is saying that it can’t find the existing repo files and just quits. It’s not finding them as this is a fresh Deadline Repo install!

Looks like you can install the 10.1.9.2 repo fine, then running the 10.1.12.1 installer afterwards to update it to the latest version.

Seems like 10.1.11.5 has the same issue as well.

I’ll send support an email and see what they say, but going the long way round will get you on your way :slight_smile:

1 Like

Hi Squeaky,

That did indeed do the trick! Many thanks :grinning_face_with_smiling_eyes:

No probs, just give me a shout if you need any help getting things working.

Well, since you’re kind enough to offer I have one more thing!

I got everything working and the client installed on one of my computers!
I now tried it on another one, same process and no errors during installation, but when trying to launch the “deadlinelauncher” I get a “Segmentation Fault (Core dumped)” which I have always found the hardest to trace…

Any idea what might cause this? My guess is missing libs but I don’t know where any logs might be situated

Are you running the monitor on Ubuntu?

I just have the repo on Ubuntu, and the clients are on Windows.

You should be able to check the log files here : /var/log/Thinkbox/Deadline[VERSION]

Privacy | Site terms | Cookie preferences