Deadline (c4d) uses different render settings for a take on every other Task

Hello!

I’m running Deadline 10.1.12.1 and the latest Cinema4d 23.110 + Redshift 3.0.45
All clients are on the same Deadline, Cinema4d and Redshift version.

I’m using a scene with 12 different takes, each one has it’s own render setting. I submitted the scene with marked takes to Deadline and let it render over night.
When I checked the files in the morning I realized that it rendered different files types for every task.
Sometime the same client rendered png at one task and jpegs for the other task.

After some testing I found out that Deadline uses the render settings from the main take for some tasks and the selected render setting (for this take) for some other tasks.
The same scenefile, on the same client, but different render settings on each task.
Frame ranges and output paths were taken correctly from the right render setting. Filetype, saving checkbox and probably other settings were taken from the selected main take setting.
I also tried “include Main take in all takes” on/off when submitting but couldn’t yield any positive results.

I can’t update our farm to the latest version of deadline right now because where in the final phase of a project.
Is this a known problem with 10.1.12.1 and c4d?

If someone is interested I can try submit a test file here.
I can’t find any issues in the logfile connecting to this problem

Thanks for you help!

takesystemtest_01.zip (48.8 KB)

Here is a simple c4d scene. The issue is not connected to redshift.
the first 20 Frames render as EXR and then the rendersettings switch.
Or do I use it wrong?

Hi
I suspect that C4D is overwriting frames rendered with previous takes, because your output path is ‘$prj/$prj’. I think it should be ‘$prj/$prj-$take’

Regards
Bonsak

Hey bonsak!
Thanks for your reply.
I used different file types for every take, so it is not overwriting the frames. Anyhow, this is not the issue I have. . I think the problem is of a different kind of nature.
The problem is that the first tasks submitted to deadline always use the the render settings out of the main take. After 3-5 Tasks it’s switching back to the selected Setting for the take.
Does this make sense?

I’m not sure if there is a mismatch with the newest version of c4d and the 10.1.12.1 of deadline but this issue never occurred with c4d Version 23.008.

I see :slight_smile:
I think i have had a similar problem once. I think the solution was to set the active take to one of the takes you are rendering (not the main take) before submitting but im not sure. Might be wrong :slight_smile:

Regards
Bonsak

Thanks! That workaround could work. I’ll try that
But you can’t render more than one shot, because you have to submit each take on it’s own…

Hmm. I will do some more testing on it, but so far it looks like a bug to me.

Mark the takes you want to render in the Takes manager and then select “Marked Takes” in the submitter.

Regards
Bonsak

I know! :smiley:
I submit the scenes always like this.
But when i do this then the above mentioned problem happens. Deadline switches render settings for each task.

Hm. Have you tried naming your takes and render settings to more unique names and also use underscore instead of white space? Just a thought…

Regards
Bonsak

Sorry it took me a while to respond. I was in the endphase of a project and couldn’t spend more time on testing.

The Problem though is still there.
I updated our Repository and the Clients to the newest version 10.1.17.4 and encountering the same bug.
I changed names in the render settings to unique names as well. No change.

In my appended example the the first 4-5 Task were rendered with the rendersettings from the main Take, then it switchtes to the assigned render settings for the following Tasks. The interesting thing is that its only switchtig the settings for “filetype”.
For expample the first 5 Task render as PNG and then rendering OPENexr… in the SAME Job! It’s not even possible to submit a job that it is rendering specific tasks with different filetypes.

I’m becoming the feeling the the deadline submission plugin for c4d may cause this problem.
Were can I find the latest version for C4D r23? Maybe I’m running a old version of it which having trouble with the new C4D version.

I can’t be the only person experiencing this.

Thanks for your input and help so far @bonsak !

Privacy | Site terms | Cookie preferences