Deadline install 'repository path is not valid'

I am trying to install Deadline Client on one of our machines and when I go to enter the repository path it says ‘The Repository Directory is invalid or does not exist’. The repository is on a server which the machine is connected to. OS is Ubuntu 14.10. This is the filepath to the server: /run/user/1000/gvfs/afp-volume:host=00-25775.local,user=dnrender,volume=Deadline
This path has worked on two other machines of the same specifications.


Can you confirm if the file share showing as mounted? Can you browse to it using the file browser? The installer is usually looking for the file at “[repo]/settings/dbConnect.xml” so that’s the file that should be located.

It is mounted, I can browse through folders and the settings folder with the dbconnect.xml is present.


Can you verify that you can also navigate through the terminal instead of file browser? That’s the method the installer would use to check for the file, and I am wondering if that is the issue. Otherwise I am not sure why the machine can’t locate the path, but you could make a faux repo by making a “[repo]/settings/dbConnect.xml” location on the machine in order to complete the install, then try to change the repo location post install.

When I attempt to navigate from terminal I get an input/output error. What does this mean?

Hello Brad,

That means that the location is not actually accessible to the user using the method Deadline uses. It likely means that the path is getting unmounted or becoming inaccessible to the user. I wonder if it’s mounted for another user, not the render user.

I discovered what the input/output error was and that was for something else. The machine is a linux machine connected to a mac file server via SMB. I can browse through folders and the two other machines that are identical to this one have the same repository setup.

Hey Brad,

I don’t know where in the world you’re located, but do you want to give us a call? We’re here 9-5 central, so you can either phone the extension in my signature or ext 2 for everyone in support.

I’m hoping some hands-on time will fix up this problem pretty quick.



Hello Brad,

Could I have you email so we can continue further trouble shooting of this? Thanks.

Update for anyone else with this problem.

It looks like when the installer is running with ‘sudo’, it might not be able to access the contents of that folder for some reason.

We fixed it by installing Deadline with “/tmp” as the Repository path, then changing the path after install from the Monitor UI.

Thing I learned today: you can access gvfs folders from /run/user just like Brad’s been doing. That’s a totally new world to me.


I’d like to add my result too.
I was running into the same issue.

Mac OSX hosting the Deadline 10 Repository
Ubuntu 18.04 mounting the repository via sshfs command

sshfs -o nonempty user@host:/Applications/Thinkbox/DeadlineRepository10 /mnt/DeadlineRepository10

I would try running the Deadline Client installer with sudo, but it would say the directory is invalid.
When I sudo su, sudo does not have access to the mounted directory.

I fixed this by changing the mount command to the following:
sudo sshfs -o nonempty -o allow_other user@host:/Applications/Thinkbox/DeadlineRepository10 /mnt/DeadlineRepository10

1 Like

You can also mount sshfs for a specific user with -o uid=james, and with a custom mapping from remote uid to local with -o idmap=user, see here.