AWS Thinkbox Discussion Forums

Deadline Monitor Support for Apple M1

Hi there,

I’d like to use Deadline Monitor on mc MacBook Pro (13-inch, M1, 2020) running Monterey.
However it seems that the current Build of Deadline Monitor for Mac is not compatible with M1 as I get a bunch of python errors when trying to launch the Monitor.
On my PC I dont get any error message connecting to the same Repo.

Here is the error message that I get on my M1 Mac:

Time to initialize: 659.000 ms
Auto Configuration: No auto configuration for Repository Path could be detected, using local configuration
ERROR: DataController threw a configuration exception during initialization: The specified repository path (/Users/goetzmoritz/deadline) does not contain the necessary database connection settings file.

There may be a network issue, or a valid repository has not been installed at this location. If one has not yet setup a repository, it is possible to do so using the repository installer included in the installation files. (Deadline.Configuration.DeadlineConfigException)
Traceback (most recent call last):
  File "UI/Forms/", line 147, in Startup
  File "C:\thinkbox-conda\conda-bld\deadline_1634169462354\work\DeadlineProject\DeadlineUI\Forms\", line 68, in __init__
ApplicationException: Error encountered when trying to open or create config file '/Users/Shared/Thinkbox/Deadline10/dconf.bin':
Access to the path '/Users/Shared/Thinkbox/Deadline10/dconf.bin' is denied.
   at FranticX.Security.ProtectedConfig.RefreshConfig(Nullable`1 timeout)
   at FranticX.Security.ProtectedConfig..ctor(String configFilePath, Boolean isUserScope)
   at Deadline.Configuration.DeadlineConfig.b(Boolean dec)
   at Deadline.Configuration.DeadlineConfig.RefreshProtectedSettings(ConfigLevel level)
   at Deadline.Configuration.DeadlineConfig.RefreshProtectedSettings()

Listener Thread - OnConnect: Listener Socket has been closed.

Thanks for checking out!


Seems to me that the cause is not having permissions to write to /Users/Shared/Thinkbox/Deadline10/dconf.bin and/or the repo is not configured to connect to the database. So not sure it’s caused by the particular platform.

Your observation is correct, actually it is due to the weird way my Mac is setup (company restrictions). This topic is closed, thank you @mois.moshev

hey guys,

Just coming upon this now.

I’ve opened up this directories permissions

but no joy - was there something else you did to solve it?


Hi Will,

Do you still get the same permissions error after changing dconf.bin?

not sure which version this is and whether you still need to allow disk permissions to /bin/sh on a mac

Hey Ant,

I actually just opened up permissions on the whole folder /Users/Shared/Thinkbox - seems I don’t have a dconf.bin in there :face_with_monocle:

Also where would that bin/sh be?

Thanks alot man

  • Open the Security & Privacy Preferences pane and select the Privacy tab
  • Select Full Disk Access from the list of services
  • Click the lock icon in the bottom left corner to unlock the interface

I had to drag and drop it rather than add it

Hey man,

hmmm tried adding DeadlineMonitor10 app into the allowed list but no joy, then tried the whole Deadline folder with still no dice. Anything else i’m missing??

Thanks alot,

add /bin/sh

best way is to add the mac to the bin :wink:
funnily enough I found a macbook in a bin, fixed the boot errors it had so I can check this myself.

System Preferences > Security & Privacy > Privacy

Scroll the left menu till you see ‘Full disk access’
Click padlock to unlock settings
Press Shift +Cmd +. to show hidden files
Choose your root drive (Macintosh HD) , then bin then sh

mail me direct if you’re still having issues

Will at FD posted that question for me. It turns out that, after reading the error log, my issue was that the version that I installed on my M1 was too new. I installed an older version of Deadline Monitor,, and all is working now.
Cheers all!

Privacy | Site terms | Cookie preferences