Deadline > Shotgun connection fail since update

We just updated from 10.0 to 10.1 and everything worked exactly as it should on all machines except 1, which now won’t connect to shotgun. If I run the 'Test Integration Connection I get the following error:

Retrieving sticky settings... done!
Connecting to Shotgun as 'xxxxxxxx'... UNEXPECTED ERROR:
<type 'exceptions.IOError'>
[Errno 2] No such file or directory
Clearing Task filters... done!

The machine can connect to shotgun via web interface, and can submit via other softwares but the Deadline>Shotgun connection is broken.

I have tried a manual client removal and reinstall, but still no joy.
It was working perfectly before the update, and all other machines work perfectly.

Any ideas?




We’ve seen this before, the fix is just a little annoying.

The workaround is to modify <DeadlineRepository>/pythonsync/, copying shotgun_api3/lib/httplib2/cacerts.txt to shotgun_api3/lib/httplib2/python2/cacerts.txt . Then restart Deadline Monitor to re-sync, and retry the integration test.

The path that fails only gets run when Shotgun is falling aback to use the default CA cert, so it could also be that the problem machine isn’t able to grab the one you’ve set.

We have done the suggested copy and still get the same error message, how do we get to read or download the certificate?

Oh, important detail, you’ll need to restart the worker so it pulls a fresh copy of pythonsync.


I’m having the same issues. I have updated the and still getting an error when trying to connect to shotgun
<type ‘exceptions.IOError’>
[Errno 2] No such file or directory

Is there a location that has a more verbose error log? I have searched around with cmin and cant find anything.

Privacy | Site terms | Cookie preferences