Deadline Worker on GCE can not get license via Cloud Interconnect

I am currently looking to use a GCE (Google Cloud Engine) instance as a Deadline Worker.
In my environment, the Deadline Repository and the license server for Deadline are located in an on-premises network, so the Worker is accessing them via Cloud Interconnect.
The Worker is up and it’s good that it was able to access the license server, but it can’t get the license. I tried to put the @ symbol at the beginning of the license server’s IP address, referring to here as a similar case study, but that didn’t solve the problem. If you know how to solve this problem, please let me know.
I’ve attached a portion of a Worker’s log as follows.

2020-08-24 16:56:12:  BEGIN - $(GCE_INSTANCE_NAME)\$(USERNAME)
2020-08-24 16:56:12:  Operating System: CentOS Linux release 7.8.2003 (Core)
2020-08-24 16:56:12:  CPU Architecture:
2020-08-24 16:56:12:  CPUs: 1
2020-08-24 16:56:12:  Video Card:
2020-08-24 16:56:12:  Deadline Worker 10.1 [v10.1.1.3 Release (a53d3f404)]
2020-08-24 16:56:12:  Error encountered when trying to fetch instance metadata, the endpoint http://169.254.169.254/latest/dynamic/instance-identity/pkcs7 does not exist
2020-08-24 16:56:12:  GetAWSInfo caught an exception The remote server returned an error: (404) Not Found. (System.Net.WebException)
2020-08-24 16:56:12:     at System.Net.HttpWebRequest.GetResponse()
2020-08-24 16:56:12:     at Deadline.AWS.AWSUtils.GetInstanceMetadata(String endpoint)
2020-08-24 16:56:12:     at Deadline.AWS.AWSUtils.GetInstanceIdentityDocument()
2020-08-24 16:56:12:     at Deadline.Slaves.Slave.c()
2020-08-24 16:56:12:  Scanning for auto configuration
2020-08-24 16:56:16:  Auto Configuration: No auto configuration for Repository Path could be detected, using local configuration
2020-08-24 16:56:16:  Connecting to repository
2020-08-24 16:56:17:  Info Thread - Created.
2020-08-24 16:56:23:  Error encountered when trying to fetch instance metadata, the endpoint http://169.254.169.254/latest/dynamic/instance-identity/pkcs7 does not exist
2020-08-24 16:57:54:  Could not obtain license because:
2020-08-24 16:57:54:  License server machine is down or not responding.
2020-08-24 16:57:54:   See the system administrator about starting the license server system, or
2020-08-24 16:57:54:   make sure you're referring to the right host (see LM_LICENSE_FILE).
2020-08-24 16:57:54:  Feature:       deadline
2020-08-24 16:57:54:  Hostname:      $(LICENSE_HOST_NAME)
2020-08-24 16:57:54:  License path:  @$(LICENSE_IP_ADDRESS):
2020-08-24 16:57:54:  FlexNet Licensing error:-96,7.  System Error: 2 "No such file or directory"
2020-08-24 16:57:54:  For further information, refer to the FlexNet Licensing documentation,
2020-08-24 16:57:54:  available at "www.flexerasoftware.com".

So that tip about using @license-server only applies if there isnt’ a port number it should be hitting. Then it should be port@license-server. The 1.1 License Server docs are better that the 1.0 version. But I bet Google took you to 1.0 :man_shrugging:

Anyways - check your license file for a port number. Should be 2708. Then try the port@license-server format.

And if that doesn’t work look at the log in the License Server’s install directory. It could be that the server itself is having trouble.

Thanks for the reply!
As per your advice, I have fixed the version of the link.

I applied the port@license-server format, but the condition remained the same (I tried port numbers 27000 to 27010 one by one).

One of the possible causes is that Worker is outputting logs about AWS even though it is using GCE.

We can ignore those calls to AWS. There’s some checks to see if the Worker is running on-prem or in one of the cloud providers. If it’s not on-prem then it tries to get info about itself from one of the EC2 endpoints.

The Worker assumes that it’s on AWS mostly because we’re deprecating the other cloud providers at some point in the future. In your case you’re not using any of the Cloud Plugins so you’re okay.

If you’re not sure what the port number is, if you look in your thinkbox.lic file that will be in the License Server’s installation directory there should be a PORT= in there so we’re sure. I’ve usually seen it set to 2708 but your license file might be different.

If you’ve tried the port number from the license file, could you check the license server log for errors? It will be in the license server’s installation directory as well.

Our team decided to use AWS EC2 instead of GCE for future official support.
We haven’t solved the root cause of the problem, but we’ve avoided the problem and I’d like to close this thread. Thank you!

Just in case this matters in the future for you or another user:

The Thinkbox License Server is using FlexLM. There are two ports involved in FlexLM - the TCP port on which you access the license, and the ISV (vendor daemon) port on which the thinkbox daemon communicates with the FlexLM server. Each license uses a different TCP and ISV port so they can share the same FlexLM license server. For example, Autodesk uses the first available port in the 27000 to 27009 range for the TCP port, Thinkbox uses 27008, and so on. The 2708 port mentioned previously is the default ISV port the Thinkbox vendor daemon uses to talk the the FlexLM license server. Autodesk uses 2080 for the vendor daemon port.

When communicating with the license server, you must specify the TCP port, so the Thinkbox license server would be typically accessed as 27008@yourlicenseserver.

When configuring port forwarding (e.g. when Deadline AWS Portal talks to the Gateway instance on AWS to forward the local licenses to the cloud), BOTH ports must be opened in the Security Groups Inbound Rules (Deadline AWS Portal does this automatically, but it might matter if you are configuring a solution manually).

Privacy | Site terms | Cookie preferences