Default Union of Spheres VS Geometry ...Horrible results?

Hi All,
When I import my particles into Frost, it gets displayed as “Union of Spheres”. Most of the particles get blended together (which I love) and give me the results I want. However due to a 2 Million + project, I am forced to use vray instancing / Geometry mode.

I cannot get my results to look the same as "Union of Spheres ", regardless of using sprits, plane, sphere, etc… They are not “melting together” as it does in Union of Spheres.

What am I doing wrong?
Images compare a viewport default VS Vray instancing/ Geometry / spheres
Notice the lack of "melting together or blending ".

This is As Designed.

Geometry mode does not do any merging of shapes. It is a straight replacement of a Particle Flow Shape operator - just replaces each particle with a geometry shape, and that’s it.

Historically speaking, the reason for this was that at some point around 2007-2008, Frantic Films was asked to work on the second X-Files movie. We were given Maya scenes and particle systems, and were asked to merely render snowflakes from those particle simulations. Since we were a 3ds Max shop, and Frost was our internal particle mesher at that time, we just added an option to replace each particle with a sprite and added the ability to align them to the camera. We textured them with snowflake images, and voila! So if you see Mulder and Scully around those police cars in the snow, some of the snowflakes were rendered using Frost.

Later we added the options to replace each particle with a sphere, box, custom geometry etc. But the idea was that if you saved a PFlow or TP out of 3ds Max with Krakatoa to PRT and wanted to replace the particles with meshes later, instead of creating a new PFlow, loading the PRTs with a Krakatoa PRT Birth/Update, and using a Shape operator, you could do the same much faster in Frost, with the added benefits of Magma controlling via channels which particle gets which custom shape…
Merging them was never a goal, and doing booleans across a million shapes would be asking for trouble…

Ah, understood . Well then my dilemma is that i was happy with the defaulted frost settup. When i did a low res test of an avalanche of snow slabs breaking apart, it look good. Once I loaded the higher res (2.5 million particles) I realized that frost was maxing out my ram and ,Frost recommended using instancing. However i would loose the metaball blending effect which gave me nice results.

Any suggestions?

How much is your RAM? Frost will take the particles and create polygons around them -depending on the settings, the number of polygons could be several times more than the number of particles. However, a mesh with 10 million or even 100 million polygons shouldn’t be a problem to render on most machines. Do you have any stats how many polygons were being generated, and how much RAM they were using?

As alternative I would suggest the VRayMetaball object. It uses, as far as I know, render-time iso-surfaces, so it might use less memory than explicit polygons. Also, it can render a Krakatoa PRT Loader’s particles (although I think it uses the native 3ds Max particles interface, so some channels like color and UVs might not make it over). I would suggest giving it a try. I just tested in VRay Next and it rendered my PRT Loader with 0 triangles in the log :slight_smile:

Hello again,
I have 48 gigs of ram (I know strange number,. long story) Normally I never have a memory issue but after I hit render, I watched the mem go from 10% to 98 % within 60 seconds. Vray gave a Bad Allocation Mem error and froze up. So I looked into Vray instancing.

Ok, I will give it another try with your recommendations and see if I can move forward.

Privacy | Site terms | Cookie preferences