DevOps Vagrant Deadline


#1

Hello to all the community,

I am a junior developer (experience 9 months) and I have to put a place the installation infrastructure of Deadline via containers (Vagrant).

The official Github offers some interesting elements, but for the RepoServer I have question for this :

Place the Deadline installer tar file (e.g., Deadline-8.0.11.2-linux-installers.tar ) in the folder that contains the file named Vagrantfile . This folder will be shared through to the VM, and this is how the provisioning script will locate the installer.

But how to have this file to test free deadline (unlicensed)?
Dirty Thinkbox provides this file for the vagrant?

Thank you in advance for your feedback

FA


#2

Contact thinkbox-sales@amazon.com , they can provide you with a license free version that i believe allows you to have up to 2 slaves running, for testing purposes.

You can then setup the command line installer to run in --mode unattended in your build script.

Hope that helps.
Kym


#3

Hello kwatts,

I found deadline file in download thinkbox sale.
I think it is possibe use it with license free.

Yes i precise --mode unattended in my script.

But i have an error that I do not understand

default: Installing Deadline Database and Repository.
default: Extracting found tar file: Deadline-9.0.12.0-linux-installers.tar
default: ./DeadlineClient-9.0.12.0-linux-x64-installer.run
default: ./DeadlineRepository-9.0.12.0-linux-x64-installer.run
default: There has been an error.
default: Error running tar -xzf “true” -C “/tmp/repoinstalltemp/mongo/”: tar (child): true: Cannot open: No such file or directory
default: tar (child): Error is not recoverable: exiting now
default: tar: Child returned status 2

In my scrpit :

printf “\nInstalling Deadline Database and Repository.\n”
cd /tmp

DL_VER=ls /vagrant/*.tar | grep -o '\([0-9]\{1,3\}.[0-9]\{1,3\}.[0-9]\{1,3\}.[0-9]\{1,3\}\)'
DL_VER_MAJOR=expr match "$DL_VER" '^\([0-9]\{1,3\}\)'
DL_TARFILENAME=Deadline-$DL_VER-linux-installers.tar
printf “Extracting found tar file: ${DL_TARFILENAME}\n”

tar -xvf /vagrant/$DL_TARFILENAME -C .

./DeadlineRepository-$DL_VER-linux-x64-installer.run
–mode unattended
–prefix $REPOPATH
–prepackagedDB true
–backuprepo true
–installmongodb true

thanks for the help of the community, I have never practiced DevOps yet

I search to test free license


#4

To double check, does your vagrant base image have a /tmp setup, since its a root level directory, you may need to make it a head of the install.

Im not familiar with vagrant, so im only guessing at this point.


#5

I resolve the problem, config.vm.network “public_network” in the vagrantfile and configure ifconfig $(number of bridge) in the script. And I had u useless line –prepackagedDB true

The script of vagrantfile for RepositoryServer working properly i think

Thanks :slight_smile:


#6

Hello everyone

I launch the virtual machine with the vagrantfile for RepoServer.

I am now trying to install the client with virtual machine and vagrant but and I have an error in one place.
I place repo-ip.txt got with RepoServer and Deadline-9.0.12.0-linux-installers.tar with the vagrantfile client

For this :

======== Mount the Share on the Repo Server ========

REPO_IP=$(<$REPO_IP_FILENAME)

echo Using Repo IP: $REPO_IP

sudo mkdir $REPO_MOUNTPOINT

printf " ${REPO_IP}:${REPO_SHARE} ${REPO_MOUNTPOINT} nfs rsize=8192,wsize=8192,timeo=5,intr

" >> /etc/fstab

cat /etc/fstab

mount -a

In my terminal i have this error

client: Using Repo IP: 10.0.2.15
client: # /etc/fstab: static file system information.
client: #
client: # Use ‘blkid’ to print the universally unique identifier for a
client: # device; this may be used with UUID= as a more robust way to name devices
client: # that works even if disks are added and removed. See fstab(5).
client: #
client: #
client: /dev/mapper/vagrant–vg-root / ext4 errors=remount-ro 0 1
client: # /boot was on /dev/sda1 during installation
client: UUID=377a57ee-b128-4940-a795-31581885806c /boot ext2 defaults 0 2
client: /dev/mapper/vagrant–vg-swap_1 none swap sw 0 0
client: 10.0.2.15:/export/repository /mnt/repository nfs rsize=8192,wsize=8192,timeo=5,intr
client:
client: mount.nfs: Connection timed out

I do not understand how to solve this error

My vagrant RepoServer is launched

Can someone help me or bring me a track

Thanks :slight_smile:


#7

Hi,
on the machine that you are developing on, can you ping or connect to the repo via the ip provided?

Have you also tried out side of the vagrant workflow to see if locally on you dev machine , if you install deadline and mount the folder you can see the repo?


#8

Hi,

With the command rcpinfo -p i have in myterminal

client: 100000 4 tcp 111 portmapper
client: 100000 3 tcp 111 portmapper
client: 100000 2 tcp 111 portmapper
client: 100000 4 udp 111 portmapper
client: 100000 3 udp 111 portmapper
client: 100000 2 udp 111 portmapper

If i do vagrant ssh and ping 10.0.2.15 I have
vagrant@client-vm:~$ ping 10.0.2.15
PING 10.0.2.15 (10.0.2.15) 56(84) bytes of data.
64 bytes from 10.0.2.15: icmp_seq=1 ttl=64 time=0.026 ms
64 bytes from 10.0.2.15: icmp_seq=2 ttl=64 time=0.029 ms
64 bytes from 10.0.2.15: icmp_seq=3 ttl=64 time=0.035 ms
64 bytes from 10.0.2.15: icmp_seq=4 ttl=64 time=0.031 ms
64 bytes from 10.0.2.15: icmp_seq=5 ttl=64 time=0.032 ms
64 bytes from 10.0.2.15: icmp_seq=6 ttl=64 time=0.027 ms
64 bytes from 10.0.2.15: icmp_seq=7 ttl=64 time=0.033 ms
64 bytes from 10.0.2.15: icmp_seq=8 ttl=64 time=0.032 ms
64 bytes from 10.0.2.15: icmp_seq=9 ttl=64 time=0.029 ms
etc

I thought maybe to a problem of firewall

I may not have understood all the manipulations you suggest (i begin in DevOps)


#9

is nfs service running on the vm that stores the repository?


#10

I do vagrant up and vagrant ssh for the vm that stores the repository. ,

I have this in my terminal
default: NFS_EXPORTS_STR: /export/repository 192.168.1.0/24(rw,nohide,insecure,no_subtree_check,async)
default: program vers proto port service
default: 100000 4 tcp 111 portmapper
default: 100000 3 tcp 111 portmapper
default: 100000 2 tcp 111 portmapper
default: 100000 4 udp 111 portmapper
default: 100000 3 udp 111 portmapper
default: 100000 2 udp 111 portmapper
default: 100005 1 udp 49939 mountd
default: 100005 1 tcp 43052 mountd
default: 100005 2 udp 51719 mountd
default: 100005 2 tcp 48722 mountd
default: 100005 3 udp 40554 mountd
default: 100005 3 tcp 52542 mountd
default: 100003 2 tcp 2049 nfs
default: 100003 3 tcp 2049 nfs
default: 100003 4 tcp 2049 nfs
default: 100227 2 tcp 2049
default: 100227 3 tcp 2049
default: 100003 2 udp 2049 nfs
default: 100003 3 udp 2049 nfs
default: 100003 4 udp 2049 nfs
default: 100227 2 udp 2049
default: 100227 3 udp 2049
default: 100021 1 udp 58661 nlockmgr
default: 100021 3 udp 58661 nlockmgr
default: 100021 4 udp 58661 nlockmgr
default: 100021 1 tcp 39115 nlockmgr
default: 100021 3 tcp 39115 nlockmgr
default: 100021 4 tcp 39115 nlockmgr
default: Restarting NFS-related services.

For this in my script

Add line to /etc/exports if needed.

NFS_EXPORTS_STR="${REPOPATH} 192.168.1.0/24(rw,nohide,insecure,no_subtree_check,async)"

echo NFS_EXPORTS_STR: $NFS_EXPORTS_STR

grep -q -F “${NFS_EXPORTS_STR}” /etc/exports || echo $NFS_EXPORTS_STR >> /etc/exports

rpcinfo -p

Refresh and restart NFS-related services.

printf “Restarting NFS-related services.\n”

exportfs -ra

service portmap restart

service nfs-kernel-server restart


#11

HI ,

At this point its not a deadline problem.
If i were in your shoes, i would try to connect locally from my workstation first, if that works and i can mount the nfs share, i would install the client, so i can test to make sure th repo works as it should.
Id then log back in to my vm , compare what packages are required to mount over nfs.

if your using centos, maybe its selinux blocking the outbound , maybe hit the vagant forums to see if this is something others have hit? Maybe try to share over samba/cifs see if its the same results.

I know in container land i need to provide credentials to mount remote paths , maybe this could also be the problem.

Maybe someone else with vagrant experience can chime in?


#12

Hi,

In vagrant ssh for the repo I do this

vagrant@repo-vm-deadline:~$ service nfs-kernel-server start
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to start ‘nfs-server.service’.
Authenticating as: vagrant, (vagrant)
Password:
==== AUTHENTICATION COMPLETE ===
vagrant@repo-vm-deadline:~$ service nfs-kernel-server status
● nfs-server.service - NFS server and services
Loaded: loaded (/lib/systemd/system/nfs-server.service; enabled; vendor preset: enabled)
Active: active (exited) since Wed 2019-07-03 16:29:05 UTC; 22min ago
Main PID: 13076 (code=exited, status=0/SUCCESS)
Tasks: 0
Memory: 0B
CPU: 0
CGroup: /system.slice/nfs-server.service

Jul 03 16:29:05 repo-vm-deadline systemd[1]: Starting NFS server and services…
Jul 03 16:29:05 repo-vm-deadline systemd[1]: Started NFS server and services.
Jul 03 16:51:29 repo-vm-deadline systemd[1]: Started NFS server and services.

But In vagrant cient the error is same client: mount.nfs: Connection timed out