Disable "Launch Slave" option from Launcher


#1

Hello,

Is there a way to disable the manual “launch slave” options from the Deadline launcher?

This is to prevent users (students) from starting the Deadline slave from their local PCs which will consume one of the Deadline licenses. (instead of using it for the actual render servers).

I have disabled “Launcher Menu” the “Everyone” group in the User Group Permissions settings but it seems not to be working.

In our environment (very large University) we have many (180+) PCs and we don’t know in advance which specific machines will be used to launch the Deadline monitor. Also, these PCs get replaced or swapped around quite frequently so manually selecting and disabling the slaves from the slave list menu is not feasible in the long term.

Thanks,
Matteo


#2

There is an deadline.ini file that has flags to control how deadline starts up.
https://docs.thinkboxsoftware.com/products/deadline/10.0/1_User%20Manual/manual/client-config.html?highlight=client%20config

i belive you want to set this:

LaunchSlaveAtStartup=False

This change can be pushed out with the software you use for client configuration, but also might be able to use deadline to push it out…

As for disabling the deadline slave in the launcher menu, that would be handled by user/ user group permissions:
https://docs.thinkboxsoftware.com/products/deadline/10.0/1_User%20Manual/manual/user-management.html?highlight=user%20permissions

you could set the default group to not have any access to launching the slave, and make it so a hand full of people can .

hope this helps


#3

I don’t think you can disable the actual menu item. However, a brute force approach would be to rename on all workstations the file Deadlineslave.exe under the ..\Thinkbox\Deadline10\bin\ folder to something else, e.g. Deadlineslave10.exe

This way, you can still launch the Slave by running the renamed EXE programmatically or manually from the File Explorer, but the Deadline Launcher will fail to find the correct EXE and will not be able to launch it if the user attempts to use the menu.

I agree that the “Launcher Menu” option in the User Group Controls should be the place to affect this, but as you mentioned, it does not seem to work. I will check with the team why that’s not behaving as expected.


#4

Thank you for you reply. I have actually tried to use the user/group permissions but they do not seem to be working. I have used the below configuration for the “Everyone” group:

but it did not do the trick. Any other idea?

Thanks,
Matteo


#5

Yes, it seems to be a bug on the interface. It would be nice to confirm it with the team and have an idea if there is a solution on your road map. Thanks. Matteo


#6

I have logged the bug and will keep you posted as I hear back from the development team.


#7

Deleting the slave.exe is a good idea, you could also create auto configuration to point only the rendernodes to the correct license server, this would avoid any other machine picking up the licenses.


#8

That’s also a good hint, let me talk to my colleagues to find the best way forward in the interim.