AWS Thinkbox Discussion Forums

DL Houdini 18.5.633 Redshift3.0.57 - RenderPluginException -- PermissionError : [Errno 13]


Some of our nodes have suddenly began to throw a permissions error relating to -

Here is the error from the log

2021-10-27 12:42:37: Exception Details
2021-10-27 12:42:37: RenderPluginException – PermissionError : [Errno 13] Permission denied: ‘C:\Users\dan\AppData\Local\Thinkbox\Deadline10\pythonAPIs\SMzpAUoJQyLqYOKF7n6GUA==\’
2021-10-27 12:42:37: RenderPluginException.Cause: JobError (2)
2021-10-27 12:42:37: RenderPluginException.Level: Major (1)
2021-10-27 12:42:37: RenderPluginException.HasSlaveLog: True
2021-10-27 12:42:37: RenderPluginException.SlaveLogFileName: C:\ProgramData\Thinkbox\Deadline10\logs\deadlineslave_renderthread_0-PROD4-0000.log
2021-10-27 12:42:37: Exception.TargetSite: Deadline.Slaves.Messaging.PluginResponseMemento d(Deadline.Net.DeadlineMessage, System.Threading.CancellationToken)
2021-10-27 12:42:37: Exception.Data: ( )
2021-10-27 12:42:37: Exception.Source: deadline
2021-10-27 12:42:37: Exception.HResult: -2146233088
2021-10-27 12:42:37: Exception.StackTrace:
2021-10-27 12:42:37: at Deadline.Plugins.SandboxedPlugin.d(DeadlineMessage bgi, CancellationToken bgj)
2021-10-27 12:42:37: at Deadline.Plugins.SandboxedPlugin.Initialize(Job job, CancellationToken cancellationToken)
2021-10-27 12:42:37: at Deadline.Slaves.SlaveRenderThread.e(String ajs, Job ajt, CancellationToken aju)
2021-10-27 12:42:37: at Deadline.Slaves.SlaveRenderThread.b(TaskLogWriter ajo, CancellationToken ajp)

Does anyone understand what the issue may be? Any help greatly appreciated!


1 Like

The issue has been solved, all be it via the nuclear option!
After unistalling DL on the client, I also deleted the [user]\AppData\Local\Thinkbox folder. This doesnt get removed during uninstall.

Then a clean reinstall of the client has fixed each node that had the issue.

1 Like

Thanks Dan!
Had the exact same error and got it resolved by uninstalling and deleting all folders from appdata

Thanks; this worked for me too.

Thank you to the OP for adding the solution. This has now worked for me (using Deadline, 3dsmax) and saved me a lot of grief in the middle of a deadline!

This issue has come back again for me.

By closing the worker and launcher, and then deleteing the Thinkbox folder in your appdata folder as above, then restarting the worker did the trick.

I didnt need to uninstall this time round. Bonus.

Privacy | Site terms | Cookie preferences