e57 conversion error: No Cartesian points


I just did an e57 export out of recap to a 38GB file. Went to load/convert in Frost/Kraktoa and am getting an error “e57_particle_istream: A scan in File “filePath” doesn’t contain Cartesian points in it.”

I think I exported it out as a complete file so that it did include per scan info, but one of the scans was turned off from viewport display. My guess is this created an empty scan block and is the cause of that error. I’m currently re-exporting it out as a unified scan so that it only contains what is visible. My ask would be - is it possible to warn that one of the scans is empty and still load the rest of them?


Hi JClarke.

I’ll log a bug report in our internal issue tracker.
Were you loading the file with a PRTLoader, or directly with a Frost object?


I have a MaxScript that tries to convert the file via FrostUtils.ConvertParticleFile, when that failed i went to the PRTloader and got the same error.


Thanks. I’ll log this right away.


This means the content of the file is probably in polar coordinates instead of cartesian. In other words, there are no XYZ positions relative to an origin, but angles and distances relative to the scanner’s origin. Currently we don’t support this format in any of our tools.

Do you have an option to convert and export cartesian coordinates out of Recap?


Ohhh, that makes sense. When you export an e57 from Recap, you get two options, one that maintains the original per-scan data, and one that ‘unifies’ the current cloud to a single file and includes any edits done in Recap. I was hoping the per scan version would give me a column identifier in magma to filter by, just in case i needed it. That file was 38GB and errored instantly as described. When i exported the same dataset in what they call the “3d only” mode, that file was only 10GB and converted to PRT just fine. Now knowing the data is structured differently in that mode and won’t work is good, I was misinterpreting the error description.