AWS Thinkbox Discussion Forums

Error: FailRenderException : 3dsmax: Failed to load max file: "C:/ProgramData/Thinkbox/Deadline10/workers/AMD32-20/jobsData/640f24e6a2763f88f4b61cf3/Testing_MAX2023_4-WEBGL.max

I am using
Deadline Client Version: Release (3b87216c7)
MAX 2023
CORONA 8(Hotfix 2)

I have 2 different logs from the deadline monitor and I don’t see where the problem is. If I download the max file from deadline, it renders locally. The max file path does load into max.

I will upload 2 logs as zips

I managed to zip and upload 2 logs (5.3 KB) (9.6 KB)


Thanks for reaching out. I looked at the logs. It seems like it is breaking because it is unable to find a dll:

2023/03/13 09:36:27 ERR: [16296] [33948] Error loading file C:/ProgramData/Thinkbox/Deadline10/workers/AMD32-20/jobsData/640f24e6a2763f88f4b61cf3/Testing_MAX2023_4-WEBGL.max

Did you test this on the render node outside of Deadline? If not then open the scene within 3dsMax on the render node and then render it within 3dsMax. Do you see the similar errors?

If it renders fine then install 3dsCmd submitter (if you are submitting job from 3dsMax else use the Monitor> Submit> 3D> 3dsCmd) and submit the same job with 3dsCmd. Share the job report here.

I didn’t see that missing DLL before. What’s strange is that we don’t use mentalray at all, never have and never will. Also note that when the scene is opened in MAX, I don’t get the Missing DLL dialog box.

I did test this on the render node outside Deadline. I download the file from deadline monitor using Auxiliary Files>Explore. Loaded it up into MAX and it does render. No errors.

According to Autodesk
“Mental Ray has been removed from 3ds Max 2018 and more recent versions of the software and has since been discontinued by NVIDIA.”


Why am I getting to different log reports from the same deadline job?


It is normal with applications like 3dsmax and Maya which run in batch mode. They keep the scene loaded and the application open in the memory and do not close them between tasks. So the first task will have the most verbose logs.

It is weird that 3dsMax is trying to load Mental Ray if Autodesk has removed it. The part of the log I have copied in my response is parsed from 3dsMax into the Deadline’s Job report. So, if you Autodesk has removed the plugin why would it still load it.
I looked on the web about how to uninstall Mental Ray and found mixed results some say it cannot be uninstalled but can be disabled and some say it can be. I cam e across this article when I was researching on how workaround those errors you are getting: "Missing Dlls" warning appears when opening a Mental Ray scene file in 3ds Max this might help here.

From the scene at the time of submission please ensure that the dlls are installed on the render node. If the dlls are not needed you can optionally enable the “Ignore Missing DLLs” feature in the SMTD at Render > 3dsmax Startup Rollout

For plugins.ini not present, copy it or create one:


Additional MAX plug-ins=C:\Program Files\Autodesk\3ds Max 20XX\PlugIns

Additional MAX plug-ins NVIDIA=C:\Program Files\Autodesk\3ds Max 20XX\PlugIns\NVIDIA\Plugins\

3DSMax 2022 and later

The issue appears to be that Deadline doesn’t load 3dsmax 2022.3 plugins which live in the now legacy standard “C:\Program Files\Autodesk\3ds Max 20XX\Plugins”.
The workaround we’ve used is to use the new 3dsmax 20XX environment variables (Help) and set ADSK_3DSMAX_PLUGINS_ADDON_DIR to C:\Program FIles\Autodesk\3ds Max 20XX\Plugins.

Did you get a chance to try 3dsCmd instead and did that work for you?



Sorry for the late reply, I’ve been away for a few days.

I did have the plugins.ini on my MAX install and I added the additional path to my max 2019 install. This got rid of the missing DLL but still won’t load the file.

I haven’t tried the 3dsCmd yet because I neglected to tell you about something. I have a custom script that I have been using since MAX 2016 and still use it on my production MAX 2019. Have also used Deadline 7 and Deadkine 10 without any issues. I want to switch to MAX 2023 but not until this issue is resolved. I submit to deadline usig STMD settings and call the submit within my script. This is the same script I am trying to use on MAX 2023 and Deadline 10.

Am I able to use 3dsCMD with a custom script?

Also is there a STMD key for ignoring missing DLL?

You custom script might not work 3dsCmd is another type of sumitter.

And yes there is ignore missing dll setting for SMTD: 3ds Max - Integrated Submitter — Deadline documentation

**Ignore Missing DLL Errors** checkbox

* Missing DLLs could mean that the 3ds Max scene cannot be loaded or rendered correctly.
* In some cases though, missing DLLs could be ignored.
* If you want the job to fail if a missing DLL message is detected at startup, keep this checkbox unchecked.

I believe the key is like below (false is the default value):


In your latest test does it fail the same way it was failing before?


I am attaching another log where I had added the mental ray path of MAX 2019 to the plugin.ini. The missing DDL isn’t there but still can not load the file. I also noticed there is a lot of reference to assemblies. Could this be causing a problem? (9.4 KB)


I can still see the same error message:
2023/03/17 15:26:40 WRN: [12036] [17036] Missing dll: mrmaterialattribs.gup - mental ray: material custom attribute

Did you apply IgnoreMissingDLLs=false ?

Our 3dsMax docs are pretty elaborative on the error you are getting can you check it out here: 3ds Max — Deadline documentation look for gup in the error messages and follow the resolution. If you already have the settings changed keep following until the end of the description of error.

Are you submitting scene with the Job? Seems like it. Can you try without submitting the scene?


Sorry I sent the wrong log. Here is the correct one. In this I added the mental ray path to the plugin.ini

I have not applied the IgnoreMissingDLLs yet. I will try later today. (3.3 KB)

Hello @KenC

I looked at this job report, it is complaining about another dll now:

2023/03/20 12:10:47 ERR: [02120] [17484] An unexpected exception has occurred in the network renderer and it is terminating.

I think if you use that missing DLL key=value it should work.



I just added the key IgnoreMissingDLLs=true to myscript and that solved the problem.

My script submits 4 renderings to deadline and the key fixed the first rendering. First issue is solved.
Now the other 3 renderings do start to render but they have an error and the rendering is not saved. I will upload a log for this.

Two different logs for the same deadline job (5.9 KB) (10.7 KB)

1 Like

From Log4.txt all we see is 3dsMax has exited without us telling it to. There are no warnings or errors to go off of.

And from Log5.txt Max doesn’t crash immediately but when Corona finishes the denoising operation. Once again, no warnings or errors that standout.

So for both I recommend working through the troubleshooting guide to get the failures on their own.



Thank you for checking the logs. I will use troubleshooting guide nad try to figure it out.

1 Like
Privacy | Site terms | Cookie preferences