AWS Thinkbox Discussion Forums

Error Installing 3ds Max Submitter on Client Node?

I’m getting this error when I try to install the 3ds Max submitter on a Win10 system that has Deadline client installed.


Could not detect the Deadline Repository Directory because there was an error running deadlinecommand.exe from C:\Program Files\Thinkbox\Deadline10\bin.

Check that the specified Deadline Client bin directory is correct.


Deadline slave is working just fine on this machine, and it’s able to connect to the repository and render jobs in slave mode just fine. The host name in the connections.ini of the machine running deadline db is resolvable as well. The submitter installer also ran fine on that host machine. Any ideas?


While this might be related to Submitter installation for Nuke fails, it might be that deadlinecommand is trying to use a certificate on a remote share for the DB communication. It’s a bit problematic because the installer is running as an administrator.

The bitrock log would give us the output from deadlinecommand and it should be obvious. The command should look something like this:

C:\Program Files\Thinkbox\Deadline10\bin\deadlinecommand -GetRepositoryRoot

I just had the same problem as OP. After much digging and messing around, I solved it.

Set the compatibility mode of the submission installer to Windows 7 and the installation should proceeded as expected when launched again. You do that in its Properties under the Compatibility tab.

Thought I’d share in case it could help anyone else. At least that worked for me.

1 Like

I have tried your suggestion Marcelo and the 3ds max submitter installer simply will not install, even using windows 7 compatibility. Is there a solution here? Or at least a manual step by step to get these max scripts installed?

The path is right, but it won’t run deadlinecommand.exe ? (which is there in the directory)

UPDATE: boy this software is frustrating to setup, but after a reboot and no success I just re-installed the client software again with the exact same install settings as before and now the 3ds max script installer works.

It is frustrating to set up, kysterama! I feel you.

It seems it’ll only go through on new Client installs.

I installed a fresh Repository ( and one new client (, updating all other Clients ( through the Repository, which updated normally. The submitter would not install.

After reading kysterama’s Update, I decided to check with the one fresh Client install and it worked without a problem. Installed a fresh Client on an auto-Repository-updated PC, and then it worked.

So. Moral of the story: Update all your clients manually to get the submitter to work!

UPDATE: Uninstall the previous Client version before installing the new one. Do not install over it because there’s a chance it won’t work. You know. Because Deadline! HA!

UPDATE 2: Our PCs have Administrator locks. Install it from the Administrator account instead of the User. That seems to work… for now.

Privacy | Site terms | Cookie preferences