Error installing Cinema4D submitter

Hello,

I am installing the submitter software for Cinema4D and is presenting the message below:

"Could not detect the Deadline Repository Directory because there was an error running deadlinecomand.exe from C: \ Program Files \ Thinkbox \ Deadline10

Check that the specified deadline client bin directory is correct "

But, the Client is installed normally and the bin folder exists as well as deadlinecommand.exe.

I don’t know what else to do to solve this problem!

He follows:

C: \ Program Files \ Thinkbox \ Deadline10 \ bin> deadlinecommand.exe -GetRepositoryRoot
D: / Repository

C: \ Program Files \ Thinkbox \ Deadline10 \ bin>

Could you help me how to solve this error?

Thanks!!

error1|427x466 error2 error3

error1

try copying the file manually, it’s just a pyp file in the repo folder, you may need to create a ‘plugins’ folder. Which version of C4D / Deadline are you using? There a couple of posts about issues with specific version

from
\\..YOURSERVERNAME..\DeadlineRepository10\submission\Cinema4D\Client\DeadlineC4DClient.pyp
to
C:\Program Files\Maxon Cinema 4D R22\plugins\DeadlineC4DClient.pyp

I am using the R23 version of Cinema 4D.

When copying the DeadlineC4DClient.pyp file manually to the folder C: \ Program Files \ Maxon Cinema 4D R23 \ plugins the “submit to deadline” does not appear.

see below:

You are supposed to provide the BIN folder of the Deadline Client. When I run the installer, it proposes

image

And the DEADLINE_PATH points at the BIN folder, too

Hello,

Even placing \ bin in the environment variables it does not let install.

see below:

What happens if you open a command window and run

deadlinecommand -GetRepositoryPath

Does it return the Repository path, or does it error out?

C:\Program Files\Thinkbox\Deadline10\bin>deadlinecommand.exe -GetRepositoryPath
Error: The specified repository path (Z:\Repository) does not exist or is not accessible from this computer.

There may be a network issue, or a valid repository has not been installed at this location. If one has not yet setup a repository, it is possible to do so using the repository installer included in the installation files. (Deadline.Configuration.DeadlineConfigException)


The Repository is located on drive Z (in another location) and not locally.

Z: is a mapped drive pointing at a share. Since mapped drives are defined per user, there is a chance that the user running deadlinecommand does not have the Z: drive mapped (while your current user might be seeing it).

Until your command prompt can execute the deadlinecommand to resolve the Repository path, no installer or submitter will be able to operate on that computer.

Out of curiosity, does the Deadline Monitor connect to the Repository on that computer?

The “Z” mapping is accessible on the machine yes!

Deadline Monitor connects to the Z too!

See below:

image


Any solution for this error?

If you try to Run Notepad.exe As Administrator, do you still see the Mapped Drive Z: in its Open and Save menus?

Do you have a Deadline10Client.pfx certificate used to connect securely to the Database? If yes, where is it stored? Is it on the Z: drive, or is it stored locally on the machine trying to connect?

We have a record of what you are experiencing, with the same error message, and in the log it shows that the certificate needed to connect to the Repository/Database cannot be accessed because it is on the mapped drive, and the drive is not mapped for the Administrator account.

When you run the Monitor from your regular account, you have both the path mapping, and probably the path to the PFX certificate, assuming you are using one.

So you either need to map Z: for the Administrator account on your machine, or copy and reconfigure the Client to read the certificate from a local drive.

1 Like

@Pedro_Borges Wow, that’s a lot of items in the ‘Extensions’ menu, that is the right place for R21> according to the docs

Mine shows up in the list, right at the end


It’s installed here
image

It doesn’t look like it from the env var screenshot you posted but do you have any custom plugin folders set with g_modulePath?

As @Bobo mentions, if it can’t see the path it needs, it won’t load the plugin, it maybe worth restarting the machine to see if that helps

Hello, I just performed this test with notepad.exe and the Z mapping did not appear:

I’m using Windows 10 Pro 20h2 build 19042.844

Could you help me?

I managed to advance the steps in the installation of the submitter.

However, is there no submitter for the R23 version of Cinema 4D?

I ran the following command on regedit:

REG ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /V EnableLUA /T REG_DWORD /D 0 /F

Privacy | Site terms | Cookie preferences