Frost submission on Deadline erroring while using PRTs


#1

I have a file that starts on frame 1001. PFlow generates particles. Saved out to PRTs. Reimported through a PRTLoader and then Frosted.

Everything seems to work fine interactively, but when submitted to Deadline, it throws an error saying that it can’t find _0000.prt. However, there is no frame 0000 because the sequence starts at 1001.

Any thoughts? Or let me know if you need more information.

Thanks!

~tsp


#2

When setting up the range, enable Custom Range and press the button that sets the Start and End frames of the range based on what is found on disk, or just enter the 1001 and the last frame manually.

When working in network mode, Max always loads its data on frame 0 first, and forces objects to update on that frame. This can cause objects to report errors on frame 0 that have nothing to do with the actual frame meant to be rendered.

As a rule of thumb, we advise our users to enable the Custom Range in their loaders when network rendering. In fact, XMesh Loader for example will set the range automatically when you pick a sequence. In the case of PRT Loader, we did not want to intrude because in practice, very often the PRT Loader was created long before the PRTs had even finished partitioning. So in that case attempting to resolve the correct frame range would be futile.


#3

Thanks again, Bobo! I’ll give it a shot!