Frost/TP/PRT Loader/XMesh loader not evaluating correctly on render


Hi guys,

We’re doing some crowds with TP and Frost and it’s very promising.
We have a TP system for the general behavior, XMesh loader for the agent animation, and Frost to instance the animation on the particles. We’re using the GeomTime channel option to play the animation synced with characters motion, looks great in the viewport.

But it doesn’t evaluate correctly on rendertime. Single frame local renders are ok, but in sequence renders there’s problems:

  • When using it straight with TP, we get renders with just a single animation frame loaded, as if the GeomTime is not evaluated
  • When caching the TP, there are no agents in the render at all
  • When caching the TP to PRT and connecting the Frost to TP, there’s the same result as in option 1 above

Having it working with TP directly would be great, it would save us the intermediate step. If that doesn’t work, no prob in caching it to PRTs too, as long as it works - we really want to go this route for the project, it’s a very efficient workflow.

Check out the scene here: … 2.max?dl=0

XMesh cache is here: … h.rar?dl=0




Could you please try changing the XMesh Loader’s “Loading Mode” to “Nearest Frame Velocity Offset”? (You can find the “Loading Mode” control near the bottom of the XMesh Loader’s “Files” rollout.)

The default loading mode, “Frame Velocity Offset”, is designed to support motion blur. If you’re rendering, say, frame 50, it will only load the mesh for frame 50. If you request the mesh for a different time, say, frame 51, it will take the mesh from frame 50, and offset it according to the Velocity. This works for motion blur, but in your case, you actually want it to load frame 51! And that’s what the “Nearest Frame Velocity Offset” mode is for. If you request frame 51, it’ll return frame 51, no matter what frame is being rendered.


Hah ok, cool to know that! Will try Monday!


Awesome, it works! Thanks :slight_smile:


Great, thank you for letting us know!