GMail for email alerts?

Is there an updated way to get alerts via Gmail? I tried with my previous settings and it doesn’t work, did something change with gmail servers? I tried with work and personal emails.

I’m going to go through the docs again and update here
There’s a blog post here
https://www.awsthinkbox.com/blog/email-notifications-from-deadline
and the documentation is here
https://docs.thinkboxsoftware.com/products/deadline/10.1/1_User%20Manual/manual/repository-config.html#email-notification
Which includes this note

If you are using Google Mail to send emails (smtp.gmail.com), you will typically use port 25 if SSL is disabled, and port 465 if SSL is enabled. See Google’s documentation on Sending Emails for more information.

The google link includes the following info for
smtp.gmail.com
smtp-relay.gmail.com
I’ve previously been (successfully) using the ‘restricted SMTP’
aspmx.l.google.com

The ports listed are
Port 25, 465, or 587
(none / SSL / TSL)

None of these are working, I’m going to dig through the Google apps / suite / workspaces / whatevertheycallitnow admin interface to see if the security thing has been changed.

(It’s here)
https://admin.google.com/AdminHome?hl=en_GB#ServiceSettings/service=email&subtab=filters

I need to go through the gmail settings and figure this out

thanks
Ant

I still never got anywhere with this

Tried with less secure switched on
https://myaccount.google.com/lesssecureapps

I’ve tried Yandex too and this also seems to fail, anyone able to recommend a service which won’t block email alerts? or does something need updating in Deadline?

1 Like

I also tried some time ago and could not get it to work. But I will try again one day :slight_smile:

1 Like

Using Gmail from a non-GUI session has been complicated for quite a few years now. They (rightfully so) want you to obtain a token to use the service API, which may include many manual steps like 2FA and “I’m not a robot” type things.

Not sure if you can use the API as a non-human user, eg. with app key and secret. Either way, I guess my ramblings aren’t really addressing your actual question.

Since you’re using the built-in email method there are probably two options here:

  1. You stumble upon the correct “insecure” SMTP settings that still work. If any
  2. Thinkbox updates their backing code for the email system to allow more modern integrations – similar to how your phone or whatever sets up a new account. This would probably require substantial development from Thinkbox

If you want to roll your own solution though, you can just tunnel your email request through a trusted third party “automation” platform like Zapier. They’ll take your money, but will make your life pretty convenient at the same time.

2 Likes

Thanks for this, zapier is a real payment cluster! I’m looking for something that will suit all users and work as it used to.

I have a ticket open for this (105274) but still not getting anywhere, last suggestion was to increase the timeout but this doesn’t change anything as the response usually comes back quickly that it didn’t work

I have it working via the smtp-relay.gmail.com on port 587 no ssl. Just had to allow access in my Google Workspaces Admin for the Relay settings.

https://admin.google.com/ac/apps/gmail/routing?hl=en

2 Likes

this way for us too!

Thanks for this info, I checked and I did have this set-up

I’m getting a (slightly) different error which seems chopped off

Attempting to send test email...
Error occurred while trying to send email:
System.Net.Mail.SmtpException - Mailbox unavailable. The server response was: 5.7.1 Invalid credentials for relay [123.45.67.89]. The IP address you've

I’ll have a dig through the gmail admin as I’m sure that IP will be set somewhere

Privacy | Site terms | Cookie preferences