Houdini 18.5 - Tasks incorrectly cooking extra nodes



Been back and forth with SideFX several times already on this ( your support never replied to me…) and the conclusion was that this is probably an issue with Deadline as SideFX couldn’t reproduce it in HQueue or running the command manually.

Houdini tasks are cooking parts of the network which should not be cooked when the scene file is loaded (hou.hipfile.load() called in hrender_dl.py). This includes OBJ nodes which have their Display Flag off and no dependents, and DOPnets which are not referenced or required by the ROP submitted to Deadline.

This is particularly bad if a scene is submitted when the timeline is not set to frame 1. In this case it seems any Dopnets in a scene are run to e.g frame 100 even though there is a cache loaded further down the network tree. This leads to hipfile load times of 10 or 20 minutes instead of 10-20 seconds.

I’ve worked around it by modifying the submitter to force the timeline back to $FSTART. But there is clearly something odd going on.

Hey Aeoll,

I wasn’t able to find a ticket in our system for the e-mail you have registered here. Feel free to reach out to me (either via DM or e-mail to amsler@amazon.com) with that so I can dig in deeper on that front.

You’re going to have to forgive me because I’m no Houdini export here. My level of understanding has me guessing that this is a simulation and we’re re-computing some work that shouldn’t be because we’re on the wrong frame. Can you provide something we could use to test with on our end and the steps required to use it? Ideally something with no external assets.

Your quick hack would also be helpful.



I’m experiencing similar issues. I can render my shots, no problem, in the houdini GUI, same with hython / hrender. But via deadline, it seems to recompute a lot of unnecessary stuff. The process chews up all the ram, all the swaps and brings everything down.

I ran into this issue pre-Houdini 18.5 (forget if it was 18 or 17.5). I noticed it when moving from to I ended up diffing the Houdini scripts and saw that quite a few blocks of code were added in and something in there was the culprit. Ended up just rolling back to My temporary fix was to put a null node in my dopnets and set the cook flag to that…obviously not a great long term fix.


I managed to recover a hrender.py file from and exchanged the broken one of the current version with it. And voila, the scene renders without recooking random things I never asked it to, using all my ram and ultimately crashing.

You guys have a MASSIVE bug there.

1 Like
Privacy | Site terms | Cookie preferences