I'm new -- TextureCoord Error

// Error: Krakatoa MY: ERROR : material_evaluation_particle_istream error: The specified UVW channel: “TextureCoord” does not appear in the delegate stream’s native channel map.

I get this error when I add a texture modifier.

Magma -
Velocity to Texture Coord

Modifiers -

  1. Magma
  2. Apply Texture
    Color for Channel Name
    UVW = Texture Coord
    Plugged in a Ramp to texture channel…

It was rendering ok with the error, but when I started a new scene and imported the PRT Loaders – Seems to error out before rendering.

Any help wold be appreciated.

THanks in advance!
Oliver :slight_smile:

Working…
I had 2 PRTLoaders…

The 2nd PRTLoader didn’t have any particles…

Still would like to know more about that error…

PRT Loaders that have no particle files specified can cause problems like this.

The reason this error occurs is that it is looking for a “TextureCoord” channel, however, the PRT Loader is reporting that it does not have that channel.

I will look into special-casing the case for PRT Loaders that have no particles files so that this error does not occur.

Thank you for the response… Guess I can create a random particle off in space that is there for the entire length of the animation.

There should be a difference between having no PRT files in the PRT Loader, and having no particles in an existing PRT sequence.
We would like to throw an error in the former case, and handle the latter gracefully, since 0 particles in a PRT file should not cause trouble.
The PRT Loader has options to be turned off and on - simply uncheck the option “Enable in Render” for the existing sequence, and it won’t try to render.
If there are 0 frame PRT files in the beginning or end of a sequence, you can also check “Use Custom Range” and set the Range Start and Range End to the actual frames that contain particles. You can set the Range Start and Range End Modes to “Blank” which will still produce 0 particles before and after the range, but will throw no error messages.

So to clarify, in your case, your second PRT Loader did have a PRT sequence, but it had 0 particles in each PRT file? Or was it a PRT Loader without a PRT sequence?

OMG I’ve been hunting for the last five hours for this solution. Frame 1 had no particles :confused:

I set my render to go from frame 2 and tadaah! Now batch works just fine.

Privacy | Site terms | Cookie preferences