Krakatoa File Sequence Editor menu disappears


#1

Hi,

I’ve been running into a weird issue with the Krakatoa Loader objects. When I start working with a scene I can see the File Sequence Editor menu just fine:
[attachment=0]Krakatoa_file_sequence_editor_Visible_.jpg[/attachment]

But it seems that if deselect the loader object, select other objects, and then select the loader object again - the File Sequence Editor menu is now missing:
[attachment=1]Krakatoa_file_sequence_editor_not_visible_.jpg[/attachment]

At first I thought there might be a bug in my scene but I tried to recreate the issue in a new scene with new loader objects and I still have the same problem. The File Sequence Editor is available at first, then if I select and deselect other objects the File Sequence Editor won’t be visible again.

Any thoughts?


#2

Hi Jim. Thanks for letting us know. I’ve logged this in our internal issue tracker.


#3

Hi Jim,

Can you report the exact versions of Max and Krakatoa you are using?
In both the original Max 2018 release, and in PU3, resizing the command panel, then deselecting and selecting again the PRT Loader resizes its UI to fit in the new width. A bug on the Autodesk side prevented the dialog from resizing back. This has been addressed somewhat in Max 2019 by allowing auto-resizing of most controls, but it would require me to rewrite the PRT Loader’s UI code once again to use the complete width.

So I wonder if you are running PU4, which might have “fixed” the command panel resizing by integrating the 2019 changes, and thus broken the PRT Loader’s width updates once again… If yes, then your only solution is not to resize the command panel, or to restart Max when the problem occurs until we add dedicated support for the new behavior.


#4

Hi Bobo,

I am running 3DS Max 2018 (2018.4 update) 20.0 - 20.4.0.4254, Krakatoa Version 2.7.0. My version of 3DS Max is set to auto install any updates so I’m assuming it’s running the most up to date version.

What’s weird is that now the problem seems to be gone!? I even tried creating a fresh new scene again, selected several different objects, and could still access all of the menus OK. I even tried resizing the command panel and it still worked fine. So I’m really not sure why I was having this issue all morning and now it’s gone… :confused:

So, sorry for the mystery problem but thanks for your help! I’ll keep you posted if this issue returns.