AWS Thinkbox Discussion Forums

Krakatoa renders in AE


I thought I had this sorted but things aren’t looking as they should in AE.

In c4d I’m rendering multi channel EXRs. In the picture viewer I turn OFF the colour profile preview so I get a result similar to the viewport render.

I have straight alpha selected, not premultiplied.

I render out, import to AE, set project to 32bit, I linearize the workspace. Now I would expect to interpret the Krakatoa render to linear light but I have to turn it OFF to get it looking like it does in C4d. Even then the colours seem off. Also the alpha doesn’t seem to be strong so when I comp it with an image it is very faint.

With Multichannel EXRs I’m using extractor, but this also happens with non multichannel EXR sequences.

I realise this is probably AE at fault rather than Krakatoa, but I wondered if anyone had any tips or a solid workflow for compositing in after effects and how to correctly interpret renders?

I’ve tried to import into Nuke also (just as a test) and I get a correct looking result when I turn off the colourspace but not when I set it to 2.2 gamma.



Ok * think * I’ve sorted this out…

What seems to work best for me is to render premultiplied and turn off linear light in the interpret settings for the Krakatoa render. Alpha still seems a little different though but is much closer.

Krakatoa does not handle the color transformations in the C4D picture viewer, so depending on your colour profile settings, they may appear differently than what is in the output exr file.

The EXR images you get out of Krakatoa is the raw data and is linear color with no transformations. When you import them into AE, just ensure it is not doing any transformation on the color, and it should be in linear color space.

These transformations can definitely get confusing. It’s hard for me to test in AE, since I do not have the software, but it should work the same as similar software, so I can take a look if something is off. Is everything still working for you?

Hi Conrad

Thanks for getting back to me.

I think that in After Effects terms that equates to ticking ‘preserve RGB’ to stop any colour transformation. And turning off linear light for the footage. I will check this though. I don’t think it’s Krakatoa’s fault, probably after effects and the colour management system which is a bit of a mystery.



Privacy | Site terms | Cookie preferences