Licensing yeti for use with arnold standalone

Hi all,

I’m really struggling with yeti renders using Arnold standalone on our farm. I cannot seem to launch kick via the arnold standalone job submission and have yeti successfully pull a license.

With mayabatch this was easy. I just edited /usr/autodesk/maya2020/bin/maya with export peregrinel_LICENSE=port@ipAddress and away we go.

Our farm jobs are run under root. I have added my export command to a .sh to /etc/profile.d/ and when I restart I can log in as root and see the peregrinel_LICENSE variable when i query env.

But my nodes can’t find it. A pre-task script reveals a completely different set of environment variables:

THINKBOX_LICENSE_FILE=10.1.1.224
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin
PWD=/opt/Thinkbox/Deadline10/bin
LANG=en_GB.UTF-8
0: _=/usr/bin/env

I have no idea where this is coming from! If I did I could probably add my yeti to the mix and be in business.

If anyone can throw some light on this I would be most grateful.

Hello!

When Deadline runs a render, it’s happening inside of sandbox with it’s own environment as you’ve found out.

In a general case, there’s a couple ways to set environment variables for rendering, talked about here - Render Environment — Deadline 10.1.15.2 documentation

But since you’re likely going to want this to be set on every Arnold job, you’ll want to check out JobPreLoad scripts. The sample shows how to set an environment variable as well! :slight_smile:

Privacy | Site terms | Cookie preferences