AWS Thinkbox Discussion Forums

Linux Slave Logs - Firewall ports

Hello All

I recently began testing deadline with nuke on Cent OS.
All works very well, can remotely restart the slave etc after opening firewall ports within firewalld upon reading this:
https://docs.thinkboxsoftware.com/products/deadline/10.0/1_User%20Manual/manual/considerations.html

One thing Im noticing however is trying to look at the logs from that linux node, from deadline monitor on my windows workstation fails. It appears to use random ports??
For eg:
A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 10.20.10.182:37797

So I opened that port, tcp and it now appears to work. But am I wrong to think that its random? It almost seemed to round robin ports for me the other day but I could be incorrect.
Or does pulling logs from slaves always use port 37797??
Thanks

No, you’re absolutely right that it’s random. You can override that with the “remote command port”.

1 Like

Edwin thanks a bunch for the prompt reply!! Now have it set to a static port and all seems well :slight_smile:
Go figure it was staring at me right in the face, just wasn’t looking at the correct spot within deadlines documentation.

All good. I’ve opened a ticket internally here that we just have that on by default and pick a sane number. We do it for the cloud instances so they can work with AWS’ security groups, so why not everyone? :slight_smile:

Ha! Whoa was not expecting this to become an internal ticket but good to hear!
Keep up the great work. Deadline has been a fantastic product to work with, and your guys documentation is very well written, and easy to understand. Take care!

I’ve seen it bite enough people that I’d like it fixed. If you were the first person to bring it up then maybe I’d have let it slide.

Hi we would love to see that link here since our remote log ports change to something random every time we reboot.

But it sends us to 403 forbidden and I can’t find this information anywhere else. Would it be possible for you to show me which file and parameter we can change to make the log port static? We’d really appreciate it

We pulled down the 10.0 documentation, here’s the 10.1 equivalent. If you don’t want to hard-code the value for every worker, you can set a farm-wide override in the repository configuration. Just be aware that if you’re running multiple Worker instances on a single machine that will result in a port collision.

Privacy | Site terms | Cookie preferences