Matte holdouts also showing pre-deformed objects

Hey guys, I notice that Krakatoa renders the intermediate object on holdout geometry as well as the actual geometry to be held out. IE: Take a torus, apply a lattice, translate the lattice, make the torus a matte object: You will see the torus as a holdout, as well as the pre-deformed lattice (tagged as an intermediate object.) I’ve noticed this with all deformed geometry (Skinned characters, deformers etc.) The fix is to find the offending intermediate object and set the visibility off.

Request: Is it possible to have Krakatoa ignore intermediate objects by default?

I’ve attached a sample file. Play to frame 4 and hit renders. The Torus and cube are both deformed via a lattice. The visibility of the intermediate object on the cube is turned off.

Krakaktoa version 2.3.0.54606

–Mike R
KrakRenderIntermediateObject.7z (4 KB)

Ah, thanks for the debug scene. Should be an easy fix. I’ll take a look.

Privacy | Site terms | Cookie preferences